freebsd man page for buf_lock

Query: buf_lock

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BUF_LOCK(9)						   BSD Kernel Developer's Manual					       BUF_LOCK(9)

NAME
BUF_LOCK -- locks a buffer
SYNOPSIS
#include <sys/param.h> #include <sys/systm.h> #include <sys/uio.h> #include <sys/bio.h> #include <sys/buf.h> int BUF_LOCK(struct buf *bp, int locktype);
DESCRIPTION
The BUF_LOCK() function locks the given buffer. If the lock is already held this call will block until it can acquire the lock unless LK_NOWAIT is set. Its arguments are: bp The buffer to lock. locktype Flags controlling the type of lock. See lockmgr(9) for details.
RETURN VALUES
A value of 0 is returned upon success. See lockmgr(9) for information on non-zero return values.
SEE ALSO
buf(9), BUF_TIMELOCK(9), BUF_UNLOCK(9), lockmgr(9)
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
July 9, 2001 BSD
Related Man Pages
lockdestroy(9) - debian
lock(9) - debian
lockmgr_args_rw(9) - debian
lockmgr_recursed(9) - debian
buf_timelock(9) - freebsd
Similar Topics in the Unix Linux Community
Unix File Permissions
Mac OS X: Based on UNIX - Solid As a Rock
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Valid separator in time and date format