freebsd man page for buf_islocked

Query: buf_islocked

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BUF_ISLOCKED(9) 					   BSD Kernel Developer's Manual					   BUF_ISLOCKED(9)

NAME
BUF_ISLOCKED -- returns the state of the lock linked to the buffer
SYNOPSIS
#include <sys/param.h> #include <sys/systm.h> #include <sys/uio.h> #include <sys/bio.h> #include <sys/buf.h> int BUF_ISLOCKED(struct buf *bp);
DESCRIPTION
The BUF_ISLOCKED() function returns the status of the lock linked to the buffer in relation to curthread. It can return: LK_EXCLUSIVE An exclusive lock is held by curthread. LK_EXCLOTHER An exclusive lock is held by someone other than curthread. LK_SHARED A shared lock is held. 0 The lock is not held by anyone.
SEE ALSO
buf(9), BUF_LOCK(9), BUF_UNLOCK(9), lockmgr(9), lockstatus(9)
AUTHORS
This manual page was written by Attilio Rao <attilio@FreeBSD.org>.
BSD
January 22, 2008 BSD
Related Man Pages
buf_timelock(9) - debian
vn_lock(9) - debian
vop_islocked(9) - freebsd
vop_lock(9) - opensolaris
vn_lock(9) - opensolaris
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Memory Leaks
Is UNIX an open source OS ?
A simple UNIXtime component in Vue.js
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?