Query: scsi_reset_notify
OS: bsd
Section: 9f
Links: bsd man pages all man pages
Forums: unix linux community forum categories
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
scsi_reset_notify(9F) Kernel Functions for Drivers scsi_reset_notify(9F) NAME
scsi_reset_notify - notify target driver of bus resets SYNOPSIS
#include <sys/scsi/scsi.h> void scsi_reset_notify(struct scsi_address *ap, int flag, void (*callback)(caddr_t), caddr_t arg); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
ap Pointer to the scsi_address structure. flag A flag indicating registration or cancellation of the notification request. callback A pointer to the target driver's reset notification function. arg The callback function argument. DESCRIPTION
scsi_reset_notify() is used by a target driver when it needs to be notified of a bus reset. The bus reset could be issued by the transport layer (e.g. the host bus adapter (HBA) driver or controller) or by another initiator. The argument flag is used to register or cancel the notification. The supported values for flag are as follows: SCSI_RESET_NOTIFY Register callback as the reset notification function for the target driver. SCSI_RESET_CANCEL Cancel the reset notification request. Target drivers can find out whether the HBA driver and controller support reset notification by checking the reset-notification capabil- ity using the scsi_ifgetcap(9F) function. RETURN VALUES
If flag is SCSI_RESET_NOTIFY, scsi_reset_notify() returns: "small and bold">DDI_SUCTheSnotification request has been accepted. DDI_FAILURE The transport layer does not support reset notification or could not accept this request. If flag is SCSI_RESET_CANCEL, scsi_reset_notify() returns: "small and bold">DDI_SUCTheSnotification request has been canceled. DDI_FAILURE No notification request was registered. CONTEXT
scsi_reset_notify() can be called from user or interrupt context. SEE ALSO
scsi_address(9S), scsi_ifgetcap(9F) Writing Device Drivers SunOS 5.10 8 Sep 1994 scsi_reset_notify(9F)
Related Man Pages |
---|
scsi_reset_notify(9f) - php |
scsi_reset_notify(9f) - minix |
scsi_reset_notify(9f) - mojave |
scsi_reset_notify(9f) - v7 |
scsi_reset_notify(9f) - xfree86 |
Similar Topics in the Unix Linux Community |
---|
Scripts without shebang |
Memory leak with awk on MacOs |
UNIX Environment Setup - (Just starting!) |
Don Cragun crossing 4500 thanks went unnoticed for more than a week - late congratulations! |