bsd man page for qprocsoff

Query: qprocsoff

OS: bsd

Section: 9f

Links: bsd man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

qprocson(9F)						   Kernel Functions for Drivers 					      qprocson(9F)

NAME
qprocson, qprocsoff - enable, disable put and service routines SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> void qprocson(queue_t *q); void qprocsoff(queue_t *q); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Pointer to the RD side of a STREAMS queue pair. DESCRIPTION
qprocson() enables the put and service routines of the driver or module whose read queue is pointed to by q. Threads cannot enter the mod- ule instance through the put and service routines while they are disabled. qprocson() must be called by the open routine of a driver or module before returning, and after any initialization necessary for the proper functioning of the put and service routines. qprocson() must be called before calling put(9F), putnext(9F), qbufcall(9F), qtimeout(9F), qwait(9F), or qwait_sig(9F). qprocsoff() must be called by the close routine of a driver or module before returning, and before deallocating any resources necessary for the proper functioning of the put and service routines. It also removes the queue's service routines from the service queue, and blocks until any pending service processing completes. The module or driver instance is guaranteed to be single-threaded before qprocson() is called and after qprocsoff() is called, except for threads executing asynchronous events such as interrupt handlers and callbacks, which must be handled separately. CONTEXT
These routines can be called from user or interrupt context. SEE ALSO
close(9E), open(9E), put(9E), srv(9E), put(9F), putnext(9F), qbufcall(9F), qtimeout(9F), qwait(9F), qwait_sig(9F) Writing Device Drivers STREAMS Programming Guide NOTES
The caller may not have the STREAM frozen during either of these calls. SunOS 5.10 11 Nov 1992 qprocson(9F)
Related Man Pages
qprocsoff(9f) - php
qprocson(9f) - php
qprocsoff(9f) - minix
qprocsoff(9f) - linux
qprocson(9f) - linux
Similar Topics in the Unix Linux Community
Simple rules of the UNIX.COM forums:
Scripts without shebang
Memory leak with awk on MacOs
UNIX Environment Setup - (Just starting!)