bsd man page for bioinit

Query: bioinit

OS: bsd

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

bioinit(9F)						   Kernel Functions for Drivers 					       bioinit(9F)

NAME
bioinit - initialize a buffer structure SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> voidbioinit(struct buf *bp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
bp Pointer to the buffer header structure. DESCRIPTION
The bioinit() function initializes a buf(9S) structure. A buffer structure contains state information which has to be initialized if the memory for the buffer was allocated using kmem_alloc(9F). This is not necessary for a buffer allocated using getrbuf(9F) because getrbuf() will call bioinit() directly. CONTEXT
The bioinit() function can be called from any context. EXAMPLES
Example 1: Using bioinit() struct buf *bp = kmem_alloc(biosize(), KM_SLEEP); bioinit(bp); /* use buffer */ SEE ALSO
biofini(9F), bioreset(9F), biosize(9F), getrbuf(9F), kmem_alloc(9F), buf(9S) Writing Device Drivers SunOS 5.10 20 Nov 1996 bioinit(9F)
Related Man Pages
bioinit(9f) - centos
bioinit(9f) - mojave
bioinit(9f) - debian
bioinit(9f) - osx
bioinit(9f) - hpux
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
UNIX Environment Setup - (Just starting!)
Don Cragun crossing 4500 thanks went unnoticed for more than a week - late congratulations!
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?