quotaon(8) System Manager's Manual quotaon(8)Name
quotaon, quotaoff - turn file system quotas on and off
/etc/quotaon [ option ... ] [ filesystem ]
/etc/quotaoff [ option ... ] [ filesystem ]
The command informs the system that disc quotas should be enabled on one or more file systems. Specified file systems must have entries in
and be mounted. Quota files must be present in the root directory of the specified file systems and be named quotas. The quotas file is
created with The quota file is updated by
The option causes to print a message for each file system whose quotas are enabled. The argument may be used in stead of a list of file
systems. It causes to enable quotas on all file systems in marked read-write. This option is normally used at boot time to enable quotas.
The command informs the system that disc quotas should be disabled on one or more file systems. The option forces a verbose message for
each file system affected. The option forces all file systems in to have their quotas disabled.
File system table
See Alsosetquota(2), fstab(5), edquota(8)
``Disk Quotas in a UNIX Environment,'' ULTRIX Supplementary Documents, Volume 3: System Manager
Check Out this Related Man Page
QUOTAON(8) BSD System Manager's Manual QUOTAON(8)NAME
quotaon, quotaoff -- turn filesystem quotas on and off
quotaon [-g] [-u] [-v] filesystem ...
quotaon [-g] [-u] [-v] -a
quotaoff [-g] [-u] [-v] filesystem ...
quotaoff [-g] [-u] [-v] -a
quotaon announces to the system that disk quotas should be enabled on one or more filesystems. quotaoff announces to the system that the
specified filesystems should have any disk quotas turned off. The filesystems specified must have entries in /etc/fstab and be mounted.
quotaon expects each filesystem to have quota files named quota.user and quota.group which are located at the root of the associated file
system. These defaults may be overridden in /etc/fstab. By default both user and group quotas are enabled.
-a If the -a flag is supplied in place of any filesystem names, quotaon/quotaoff will enable/disable all the filesystems indicated in
/etc/fstab to be read-write with disk quotas. By default only the types of quotas listed in /etc/fstab are enabled.
-g Only group quotas listed in /etc/fstab should be enabled/disabled.
-u Only user quotas listed in /etc/fstab should be enabled/disabled.
-v Causes quotaon and quotaoff to print a message for each filesystem where quotas are turned on or off.
Specifying both -g and -u is equivalent to the default.
quota.user at the filesystem root with user quotas
quota.group at the filesystem root with group quotas
/etc/fstab filesystem table
SEE ALSO quota(1), libquota(3), fstab(5), edquota(8), quotacheck(8), repquota(8)HISTORY
The quotaon command appeared in 4.2BSD.
BSD December 11, 1993 BSD
Hi, I'm trying to setup user quotas on my Linux system.
It is Suse 7.3 running the standard kernel from that release.
When I try to run quotaon, I get the following:
# quotaon -v /dev/hdc1
quotaon: using /home/aquota.user on /dev/hdc1: Invalid argument
I can't figure out what it means by... (1 Reply)
Is there a way to set the size of the home directory for every single user in a specific group, in more details:
I have a group & i will have to add about 20 users to it to be their home directories. i want each of the home directories for this group to be limited to 50 MB
Help? (11 Replies)
I keep on getting an error on my site saying
I've got a 250GB dedicated server, and have used less than 200mb of that.
The site has only been on the server for just over a month.
What does this mean and how can I sort it? (8 Replies)
I have this so far:
if ; then
echo "$FOLDER too big" | /usr/sbin/sendmail $MAILADRES
But i need to figure out how to have it search all the users on the system and then find... (2 Replies)
I want to apply the user quota, but i am unable to apply the quota to user.
Kindly provide the guide line, so that i can sortout the problem.
Step 1: Create partion on device
#fdisk /dev/sda (because hard disk is scsi)
#n (new partition table) i.e /dev/sda8.
#p ( to print the partition... (2 Replies)
I am running on CentOS 5.3 x86 64bit.
I setup quotas on /home as I thought successfully, I tested numerous times with a couple of different users. I login this morning and find my /home near 100% wondering what happened.
I have one user that some how blew through his 3.5 gig quota and... (1 Reply)
I am trying to set quotas on /export/home filesystem for some of our users on a Solaris Zone I know that you would be redirecting me to some of the documentation pages, but I have already done that.
The /export/home on the Zone is a Veritas FS and I cannot see an entry for... (4 Replies)
What is the command or how to create a user with the restricted usage of space on a disk.
Also let me know how to change the limit of the space size allotted in future for the same user.
~Vinodh Kumar V M (3 Replies)
Whats the best method of setting lvm user quota? I saw both of these and I am not sure which to use.
Linux File System Quotas
Howtos Linux-Vserver With LVM And Quotas - 5dollarwhitebox.org Media Wiki (1 Reply)
Hello.. I wrote the following shell script to run disk quotas for assigning limits to users. I need to know the partition which the user has created and mount it. So i copied the partitions (which will be displayed after running fdisk -l) and separted the last line from it and cut the required... (0 Replies)