iocblk(9S) Data Structures for Drivers iocblk(9S)NAME
iocblk - STREAMS data structure for the M_IOCTL message type
SYNOPSIS
#include <sys/stream.h>
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
DESCRIPTION
The iocblk data structure is used for passing M_IOCTL messages.
STRUCTURE MEMBERS
int ioc_cmd; /* ioctl command type */
cred_t *ioc_cr; /* full credentials */
uint_t ioc_id; /* ioctl id */
uint_t ioc_flag; /* ioctl flags */
uint_t ioc_count; /* count of bytes in data field */
int ioc_rval; /* return value */
int ioc_error; /* error code */
SEE ALSO
STREAMS Programming Guide
SunOS 5.10 13 Nov 1996 iocblk(9S)
Check Out this Related Man Page
mioc2ack(9F) Kernel Functions for Drivers mioc2ack(9F)NAME
mioc2ack - Convert an M_IOCTL message to an M_IOCACK message
SYNOPSIS
#include <sys/stream.h>
#include <sys/strsun.h>
void mioc2ack(mblk_t *mp, mblk_t *dp, size_t count, int rval);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
mp M_IOCTL message.
dp Payload to associate with M_IOCACK message.
count Value to set the ioc_count of the iocblk(9S) to.
rval Value to set the ioc_rval of the iocblk(9S) to.
DESCRIPTION
The mioc2ack() function converts an M_IOCTL message into an M_IOCACK message using the supplied arguments.
To convert the message, mioc2ack() changes the message type to M_IOCACK, sets the ioc_count and ioc_rval members of the iocblk(9S) associ-
ated with mp to the passed-in values, and clears the ioc_error field. Further, it frees any message blocks chained off of mp->b_cont and
resets mp->b_cont to dp. Finally, if dp is not NULL, mioc2ack() resets dp->b_wptr to be dp->b_rptr + count (that is, it sets dp to be
exactly count bytes in length).
RETURN VALUES
None.
CONTEXT
This function can be called from user, kernel or interrupt context.
SEE ALSO miocack(9F), miocnak(9F), iocblk(9S)
STREAMS Programming Guide
SunOS 5.10 9 June 2004 mioc2ack(9F)
Hi, i have a file like this:
A1
kdfjdljfdkljfdlf
A2
lfjdlfkjddkjf
A3
***no hit***
A4
ldjfldjfdk
A5
***no hit***
A6
jldfjdlfjdlkfjd
I want to remove the lines "***no hit*** and their above line to get an output file like this: (11 Replies)
Not my story, but interesting enough to be worth posting here IMHO. (Original is here)
The following is the 500-mile email story in the form it originally appeared, in a post to sage-members on Sun, 24 Nov 2002.:
From trey@sage.org Fri Nov 29 18:00:49 2002
Date: Sun, 24 Nov 2002 21:03:02... (3 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
Hi gurus,
I have a weird requirement. I need to convert the number to english lecture.
I have 1.2 ....19 numbers
I need to convert to first second third fourth, fifth, sixth...
Is there any way convert it using unix command?
thanks in advance. (8 Replies)
Hi,
Humorous UNIX Commands shows a fun way of using echo and dc to sort of obfuscate a string.
% echo 'sasb3135071790101768542287578439snlbxq'|dc
GET A LIFE!
I am just wanting to know if there is a way to sort of use dc and echo to print out an obfuscated/garbled string instead... (3 Replies)
Hi All,
Having recently started a new job, a Data Center Migration in fact I have been tasked with looking at some of the older Solaris boxes when I came across this little gem.
nismas# uname -a
SunOS nismas 5.5.1 Generic_103640-27 sun4u sparc SUNW,Ultra-1
nismas# uptime
10:37am up 2900... (2 Replies)
For any SunOS 5.XX release, it appears prior to the "login:" prompt (as if a "uname" command is run).
Would anyone know where that initial display of SunOS release comes from upon a remote login and how I can stop if from displaying?
Thank you (4 Replies)
I am trying to remove each line in which $2 is FP or RFP. I believe the below will remove one instance but not both. Thank you :).
file
12
123 FP
11
10 RFP
awk
awk -F'\t' '
$2 != "FP"' file
desired output
12
11 (6 Replies)
Hi everybody,
Which Unix base OS have best performance for HOST virtualization?
I tested SmartOS but it needs another OS to connect remotely!
Thanks in advance. (11 Replies)
I have this file:
>ID1
AA
>ID2
TTTTTT
>ID-3
AAAAAAAAA
>ID4
TTTTTTGGAGATCAGTAGCAGATGACAG-GGGGG-TGCACCCC
Add I am trying to use this script to output sequences longer than 15 characters:
sed -r '/^>/N;{/^.{,15}$/d}'
The desire output would be this:
>ID4... (8 Replies)
Hi,
I am having contents in a file like below,
cat testfile
rpool/swap
rpool/swap14
rpool/swap2
rpool/swap3
I want to sort the above contents like,
rpool/swap
rpool/swap2
rpool/swap3
rpool/swap14
I have tried in this way, (7 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)