strcmp(9F) Kernel Functions for Drivers strcmp(9F)
NAME
strcmp, strcasecmp, strncasecmp, strncmp - compare two null-terminated strings.
SYNOPSIS
#include <sys/ddi.h>
int strcmp(const char *s1, const char *s2);
int strcasecmp(const char *s1, const char *s2);
int strncasecmp(const char *s1, const char *s2, size_t n);
int strncmp(const char *s1, const char *s2, size_t n);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
s1, s2 Pointers to character strings.
n Count of characters to be compared.
DESCRIPTION
strcmp()
strcmp() returns 0 if the strings are the same, or the integer value of the expression (*s1 - *s2) for the last characters compared if
they differ.
strcasecmp(), strncasecmp()
The strcasecmp() and strncasecmp() functions are case-insensitive versions of strcmp() and strncmp(), respectively, described in this sec-
tion. They assume the ASCII character set and ignore differences in case when comparing lowercase and uppercase characters.
strncmp()
strncmp() returns 0 if the first n characters of s1 and s2 are the same, or (*s1 - *s2) for the last characters compared if they dif-
fer.
RETURN VALUES
strcmp() returns 0 if the strings are the same, or (*s1 - *s2) for the last characters compared if they differ.
strcasecmp() and strncasecmp() return values in the same fashion as strcmp() and strncmp(), respectively.
strncmp() returns 0 if the first n characters of strings are the same, or (*s1 - *s2) for the last characters compared if they differ.
CONTEXT
These functions can be called from user or interrupt context.
SEE ALSO
Writing Device Drivers
SunOS 5.10 1 Apr 1994 strcmp(9F)