Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

miocpullup(9f) [sunos man page]

miocpullup(9F)						   Kernel Functions for Drivers 					    miocpullup(9F)

NAME
miocpullup - Prepare the payload of an M_IOCTL message for access SYNOPSIS
#include <sys/stream.h> #include <sys/strsun.h> int miocpullup(mblk_t *mp, size_t size); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
mp M_IOCTL message. size Number of bytes to prepare. DESCRIPTION
The miocpullup() function prepares the payload of the specified M_IOCTL message for access by ensuring that it consists of at least size bytes of data. If the M_IOCTL message is transparent, or its total payload is less than size bytes, an error is returned. Otherwise, the payload is con- catenated as necessary to provide contiguous access to at least size bytes of data. As a special case, if size is zero, miocpullup() returns successfully, even if no payload exists. RETURN VALUES
Zero is returned on success. Otherwise an errno value is returned indicating the problem. CONTEXT
This function can be called from user, kernel or interrupt context. SEE ALSO
STREAMS Programming Guide SunOS 5.10 9 June 2004 miocpullup(9F)

Check Out this Related Man Page

mcopyout(9F)						   Kernel Functions for Drivers 					      mcopyout(9F)

NAME
mcopyout - Convert an M_IOCTL or M_IOCDATA message to an M_COPYOUT SYNOPSIS
#include <sys/stream.h> #include <sys/strsun.h> void mcopyout(mblk_t *mp, void *private, size_t size, void *useraddr, mblk_t *dp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
mp M_IOCTL or M_IOCDATA message. private Value to set the cq_private field of the copyreq(9S) to. size Value to set the cq_size field of the copyreq(9S) to. useraddr Optionally, the value to set the cq_addr field of the copyreq(9S) to. dp Optionally, the payload to copy out. DESCRIPTION
The mcopyout() function converts an M_IOCTL or M_IOCDATA message into an M_COPYOUT message using the supplied arguments. To convert the message, mcopyout() changes the message type to M_COPYOUT, and its payload from a iocblk(9S) to a copyreq(9S). Since the iocblk(9S) and copyreq(9S) are designed to overlay one another, the only fields which must be updated are cq_private, cq_size, and cq_addr, which are set to the supplied values. If useraddr is passed as NULL, the M_IOCTL must be transparent and cq_addr is assigned the pointer- sized quantity found at mp->b_cont->b_rptr. If dp is not NULL, any trailing message blocks associated with mp are freed, mp->b_cont is reset to dp and dp->b_wptr is set to dp->b_rptr + size. Otherwise, any trailing message blocks are unaffected. RETURN VALUES
None. CONTEXT
This function can be called from user, kernel or interrupt context. SEE ALSO
mcopyin(9F), copyreq(9S), iocblk(9S) STREAMS Programming Guide SunOS 5.11 9 June 2004 mcopyout(9F)
Man Page