ldi_remove_event_handler(9F) Kernel Functions for Drivers ldi_remove_event_handler(9F)NAME
ldi_remove_event_handler - Remove an NDI event service callback
SYNOPSIS
#include <sys/sunldi.h>
int ldi_remove_event_handler(ldi_handle_t lh, ldi_callback_id_t id);
INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI)
PARAMETERS
ldi_handle_t lh Layered handle representing the device for which the event notification is requested.
ldi_callback_id_t id Unique system-wide registration ID returned by ldi_add_event_handler(9F) upon successful registration.
DESCRIPTION
The ldi_remove_event_handler() function removes the callback handler specified by the registration ID (ldi_callback_id_t). Upon successful
removal, the callback handler is removed from the system and is not invoked at the event occurance.
RETURN VALUES
DDI_SUCCESS Callback handler removed successfully.
DDI_FAILURE Failed to remove callback handler.
CONTEXT
This function can be called from user and kernel contexts only.
SEE ALSO ldi_add_event_handler(9F), ldi_get_eventcookie(9F)
Writing Device Drivers
SunOS 5.10 9 Feb 2004 ldi_remove_event_handler(9F)
Check Out this Related Man Page
ddi_remove_event_handler(9F) Kernel Functions for Drivers ddi_remove_event_handler(9F)NAME
ddi_remove_event_handler - remove an NDI event service callback handler
SYNOPSIS
#include <sys/dditypes.h>
#include <sys/sunddi.h>
int ddi_remove_event_handler(ddi_registration_id_t id);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
ddi_registration_id_t id
Unique system wide registration ID return by ddi_add_event_handler(9F) upon successful registration.
DESCRIPTION
The ddi_remove_event_handler() function removes the callback handler specified by the registration id (ddi_registration_id_t). Upon suc-
cessful removal, the callback handler is removed from the system and will not be invoked in the face of the event.
RETURN VALUES
DDI_SUCCESS
Callback handler removed successfully.
DDI_FAILURE
Failed to remove callback handler.
CONTEXT
The ddi_remove_event_handler() function can be called from user and kernel contexts only.
ATTRIBUTES
See attributes(5) for a description of the following attributes:
+-----------------------------+-----------------------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+-----------------------------+-----------------------------+
|Stability Level |Evolving |
+-----------------------------+-----------------------------+
SEE ALSO attributes(5), ddi_add_event_handler(9F), ddi_get_eventcookie(9F)
Writing Device Drivers
NOTES
Device drivers must remove all registered callback handlers before detach(9E) processing for that device instance is complete.
SunOS 5.10 2 May 2003 ddi_remove_event_handler(9F)
Man Page
5 More Discussions You Might Find Interesting
1. Post Here to Contact Site Administrators and Moderators
Hi All,
I need to extract the last occurance of a pattern match. So far I've got the code below which extracts the first occurance. Any ideas how I can modify it so that it extracts the last?
BEGIN {}
{
if (data++ == 0)
... (17 Replies)
Hi,
I am new to Unix world. Is there any command which can directly return the second occurance of a particular string in a file? Basically, I want to read the contents of the file from the second occurance of a particualr string. Can be implemented using a loop, but am just wondering if there... (5 Replies)
I have a file with a bunch of similar lines in which I want to extract a phrase delimited by the first occurance of a '>' at the beginning and the first occurance of a '<' at the end (you might have guessed these are beginning/end of HTML tags). Using Sed I have managed to delete up to and... (7 Replies)
Hi
I have a file which contains the following two lines which are same But I would like to insert the value=8.8.8.8 in the 1st occurance line and value=9.9.9.9 in the 2nd occurance line.
<parameter name="TestIp1" value="">
<parameter name="TestIp1" value="">
Please suggest (1 Reply)