ddi_get_parent(9F) Kernel Functions for Drivers ddi_get_parent(9F)NAME
ddi_get_parent - find the parent of a device information structure
SYNOPSIS
#include <sys/ddi.h>
#include <sys/sunddi.h>
dev_info_t *ddi_get_parent(dev_info_t *dip);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
dip Pointer to a device information structure.
DESCRIPTION
ddi_get_parent() returns a pointer to the device information structure which is the parent of the one pointed to by dip.
RETURN VALUES
ddi_get_parent() returns a pointer to a device information structure.
CONTEXT
ddi_get_parent() can be called from user or interrupt context.
SEE ALSO
Writing Device Drivers
SunOS 5.10 5 Oct 1991 ddi_get_parent(9F)
Check Out this Related Man Page
ddi_dev_is_sid(9F) Kernel Functions for Drivers ddi_dev_is_sid(9F)NAME
ddi_dev_is_sid - tell whether a device is self-identifying
SYNOPSIS
#include <sys/conf.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>
int ddi_dev_is_sid(dev_info_t *dip);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
dip A pointer to the device's dev_info structure.
DESCRIPTION
ddi_dev_is_sid() tells the caller whether the device described by dip is self-identifying, that is, a device that can unequivocally tell
the system that it exists. This is useful for drivers that support both a self-identifying as well as a non-self-identifying variants of a
device (and therefore must be probed).
RETURN VALUES
DDI_SUCCESS Device is self-identifying.
DDI_FAILURE Device is not self-identifying.
CONTEXT
ddi_dev_is_sid() can be called from user or interrupt context.
EXAMPLES
1 ...
2 int
3 bz_probe(dev_info_t *dip)
4 {
5 ...
6 if (ddi_dev_is_sid(dip) == DDI_SUCCESS) {
7 /*
8 * This is the self-identifying version (OpenBoot).
9 * No need to probe for it because we know it is there.
10 * The existence of dip && ddi_dev_is_sid() proves this.
11 */
12 return (DDI_PROBE_DONTCARE);
13 }
14 /*
15 * Not a self-identifying variant of the device. Now we have to
16 * do some work to see whether it is really attached to the
17 * system.
18 */
19 ...
SEE ALSO probe(9E) Writing Device Drivers
SunOS 5.10 24 Oct 1991 ddi_dev_is_sid(9F)
Hi, i have a file like this:
A1
kdfjdljfdkljfdlf
A2
lfjdlfkjddkjf
A3
***no hit***
A4
ldjfldjfdk
A5
***no hit***
A6
jldfjdlfjdlkfjd
I want to remove the lines "***no hit*** and their above line to get an output file like this: (11 Replies)
Not my story, but interesting enough to be worth posting here IMHO. (Original is here)
The following is the 500-mile email story in the form it originally appeared, in a post to sage-members on Sun, 24 Nov 2002.:
From trey@sage.org Fri Nov 29 18:00:49 2002
Date: Sun, 24 Nov 2002 21:03:02... (3 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
Hi gurus,
I have a weird requirement. I need to convert the number to english lecture.
I have 1.2 ....19 numbers
I need to convert to first second third fourth, fifth, sixth...
Is there any way convert it using unix command?
thanks in advance. (8 Replies)
Hi,
Humorous UNIX Commands shows a fun way of using echo and dc to sort of obfuscate a string.
% echo 'sasb3135071790101768542287578439snlbxq'|dc
GET A LIFE!
I am just wanting to know if there is a way to sort of use dc and echo to print out an obfuscated/garbled string instead... (3 Replies)
Hi All,
Having recently started a new job, a Data Center Migration in fact I have been tasked with looking at some of the older Solaris boxes when I came across this little gem.
nismas# uname -a
SunOS nismas 5.5.1 Generic_103640-27 sun4u sparc SUNW,Ultra-1
nismas# uptime
10:37am up 2900... (2 Replies)
For any SunOS 5.XX release, it appears prior to the "login:" prompt (as if a "uname" command is run).
Would anyone know where that initial display of SunOS release comes from upon a remote login and how I can stop if from displaying?
Thank you (4 Replies)
I am trying to remove each line in which $2 is FP or RFP. I believe the below will remove one instance but not both. Thank you :).
file
12
123 FP
11
10 RFP
awk
awk -F'\t' '
$2 != "FP"' file
desired output
12
11 (6 Replies)
Hi everybody,
Which Unix base OS have best performance for HOST virtualization?
I tested SmartOS but it needs another OS to connect remotely!
Thanks in advance. (11 Replies)
I have this file:
>ID1
AA
>ID2
TTTTTT
>ID-3
AAAAAAAAA
>ID4
TTTTTTGGAGATCAGTAGCAGATGACAG-GGGGG-TGCACCCC
Add I am trying to use this script to output sequences longer than 15 characters:
sed -r '/^>/N;{/^.{,15}$/d}'
The desire output would be this:
>ID4... (8 Replies)
Hi,
I am having contents in a file like below,
cat testfile
rpool/swap
rpool/swap14
rpool/swap2
rpool/swap3
I want to sort the above contents like,
rpool/swap
rpool/swap2
rpool/swap3
rpool/swap14
I have tried in this way, (7 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)