Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_device_copy(9f) [sunos man page]

ddi_device_copy(9F)					   Kernel Functions for Drivers 				       ddi_device_copy(9F)

NAME
ddi_device_copy - copy data from one device register to another device register SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_device_copy(ddi_acc_handle_t src_handle, caddr_t src_addr, ssize_t src_advcnt, ddi_acc_handle_t dest_handle, caddr_t dest_addr, ssize_t dest_advcnt, size_t bytecount, uint_t dev_datasz); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
src_handle The data access handle of the source device. src_addr Base data source address. src_advcnt Number of dev_datasz units to advance on every access. dest_handle The data access handle of the destination device. dest_addr Base data destination address. dest_advcnt Number of dev_datasz units to advance on every access. bytecount Number of bytes to transfer. dev_datasz The size of each data word. Possible values are defined as: "15">DDI_DATA_SZ01_ACC 1 byte data size DDI_DATA_SZ02_ACC 2 bytes data size DDI_DATA_SZ04_ACC 4 bytes data size DDI_DATA_SZ08_ACC 8 bytes data size DESCRIPTION
ddi_device_copy() copies bytecount bytes from the source address, src_addr, to the destination address, dest_addr. The attributes encoded in the access handles, src_handle and dest_handle, govern how data is actually copied from the source to the destination. Only matching data sizes between the source and destination are supported. Data will automatically be translated to maintain a consistent view between the source and the destination. The translation may involve byte-swapping if the source and the destination devices have incompatible endian characteristics. The src_advcnt and dest_advcnt arguments specifies the number of dev_datasz units to advance with each access to the device addresses. A value of 0 will use the same source and destination device address on every access. A positive value increments the corresponding device address by certain number of data size units in the next access. On the other hand, a negative value decrements the device address. The dev_datasz argument determines the size of the data word on each access. The data size must be the same between the source and destina- tion. RETURN VALUES
ddi_device_copy() returns: DDI_SUCCESS Successfully transferred the data. DDI_FAILURE The byte count is not a multiple dev_datasz. CONTEXT
ddi_device_copy() can be called from user, kernel, or interrupt context. SEE ALSO
ddi_regs_map_free(9F), ddi_regs_map_setup(9F) Writing Device Drivers SunOS 5.10 15 Nov 1996 ddi_device_copy(9F)

Check Out this Related Man Page

ddi_rep_get8(9F)					   Kernel Functions for Drivers 					  ddi_rep_get8(9F)

NAME
ddi_rep_get8, ddi_rep_get16, ddi_rep_get32, ddi_rep_get64, ddi_rep_getw, ddi_rep_getl, ddi_rep_getll, ddi_rep_getb - read data from the mapped memory address, device register or allocated DMA memory address SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> void ddi_rep_get8(ddi_acc_handle_t handle, uint8_t *host_addr, uint8_t *dev_addr, size_t repcount, uint_t flags); void ddi_rep_get16(ddi_acc_handle_t handle, uint16_t *host_addr, uint16_t *dev_addr, size_t repcount, uint_t flags); void ddi_rep_get32(ddi_acc_handle_t handle, uint32_t *host_addr, uint32_t *dev_addr, size_t repcount, uint_t flags); void ddi_rep_get64(ddi_acc_handle_t handle, uint64_t *host_addr, uint64_t *dev_addr, size_t repcount, uint_t flags); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
handle The data access handle returned from setup calls, such as ddi_regs_map_setup(9F). host_addr Base host address. dev_addr Base device address. repcount Number of data accesses to perform. flags Device address flags: DDI_DEV_AUTOINCR Automatically increment the device address, dev_addr, during data accesses. DDI_DEV_NO_AUTOINCR Do not advance the device address, dev_addr, during data accesses. DESCRIPTION
These routines generate multiple reads from the mapped memory or device register. repcount data is copied from the device address, dev_addr, to the host address, host_addr. For each input datum, the ddi_rep_get8(), ddi_rep_get16(), ddi_rep_get32(), and ddi_rep_get64() functions read 8 bits, 16 bits, 32 bits, and 64 bits of data, respectively, from the device address, dev_addr. dev_addr and host_addr must be aligned to the datum boundary described by the function. Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle. The translation may involve byte-swapping if the host and the device have incompatible endian char- acteristics. When the flags argument is set to DDI_DEV_AUTOINCR, these functions treat the device address, dev_addr, as a memory buffer location on the device and increment its address on the next input datum. However, when the flags argument is to DDI_DEV_NO_AUTOINCR, the same device address will be used for every datum access. For example, this flag may be useful when reading from a data register. RETURN VALUES
These functions return the value read from the mapped address. CONTEXT
These functions can be called from user, kernel, or interrupt context. SEE ALSO
ddi_get8(9F), ddi_put8(9F), ddi_regs_map_free(9F), ddi_regs_map_setup(9F), ddi_rep_put8(9F) NOTES
The functions described in this manual page previously used symbolic names which specified their data access size; the function names have been changed so they now specify a fixed-width data size. See the following table for the new name equivalents: +-----------------------------+-----------------------------+ | Previous Name | New Name | |ddi_rep_getb |ddi_rep_get8 | |ddi_rep_getw |ddi_rep_get16 | |ddi_rep_getl |ddi_rep_get32 | |ddi_rep_getll |ddi_rep_get64 | +-----------------------------+-----------------------------+ SunOS 5.10 10 Aug 1996 ddi_rep_get8(9F)
Man Page