Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_dev_is_sid(9f) [sunos man page]

ddi_dev_is_sid(9F)					   Kernel Functions for Drivers 					ddi_dev_is_sid(9F)

NAME
ddi_dev_is_sid - tell whether a device is self-identifying SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dev_is_sid(dev_info_t *dip); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
dip A pointer to the device's dev_info structure. DESCRIPTION
ddi_dev_is_sid() tells the caller whether the device described by dip is self-identifying, that is, a device that can unequivocally tell the system that it exists. This is useful for drivers that support both a self-identifying as well as a non-self-identifying variants of a device (and therefore must be probed). RETURN VALUES
DDI_SUCCESS Device is self-identifying. DDI_FAILURE Device is not self-identifying. CONTEXT
ddi_dev_is_sid() can be called from user or interrupt context. EXAMPLES
1 ... 2 int 3 bz_probe(dev_info_t *dip) 4 { 5 ... 6 if (ddi_dev_is_sid(dip) == DDI_SUCCESS) { 7 /* 8 * This is the self-identifying version (OpenBoot). 9 * No need to probe for it because we know it is there. 10 * The existence of dip && ddi_dev_is_sid() proves this. 11 */ 12 return (DDI_PROBE_DONTCARE); 13 } 14 /* 15 * Not a self-identifying variant of the device. Now we have to 16 * do some work to see whether it is really attached to the 17 * system. 18 */ 19 ... SEE ALSO
probe(9E) Writing Device Drivers SunOS 5.10 24 Oct 1991 ddi_dev_is_sid(9F)

Check Out this Related Man Page

ddi_dev_is_sid(9F)					   Kernel Functions for Drivers 					ddi_dev_is_sid(9F)

NAME
ddi_dev_is_sid - tell whether a device is self-identifying SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dev_is_sid(dev_info_t *dip); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
dip A pointer to the device's dev_info structure. DESCRIPTION
ddi_dev_is_sid() tells the caller whether the device described by dip is self-identifying, that is, a device that can unequivocally tell the system that it exists. This is useful for drivers that support both a self-identifying as well as a non-self-identifying variants of a device (and therefore must be probed). RETURN VALUES
DDI_SUCCESS Device is self-identifying. DDI_FAILURE Device is not self-identifying. CONTEXT
ddi_dev_is_sid() can be called from user or interrupt context. EXAMPLES
1 ... 2 int 3 bz_probe(dev_info_t *dip) 4 { 5 ... 6 if (ddi_dev_is_sid(dip) == DDI_SUCCESS) { 7 /* 8 * This is the self-identifying version (OpenBoot). 9 * No need to probe for it because we know it is there. 10 * The existence of dip && ddi_dev_is_sid() proves this. 11 */ 12 return (DDI_PROBE_DONTCARE); 13 } 14 /* 15 * Not a self-identifying variant of the device. Now we have to 16 * do some work to see whether it is really attached to the 17 * system. 18 */ 19 ... SEE ALSO
probe(9E) Writing Device Drivers SunOS 5.10 24 Oct 1991 ddi_dev_is_sid(9F)
Man Page

7 More Discussions You Might Find Interesting

1. Programming

Linux Device Drivers

Here is a cool book. And the price is right! Linux Device Drivers, 2nd Edition (0 Replies)
Discussion started by: Perderabo
0 Replies

2. UNIX for Advanced & Expert Users

who - PC Computer name

Does anyone know of a way of identifying the PC / client name rather than IP address via who or some other AIX command (5.3). (4 Replies)
Discussion started by: gefa
4 Replies

3. SCO

SCO6: Upgrading nd: no intel gigabit drivers?

I just (re)installed SCO6 here from scratch because I am hunting a problem. So, I installed it, then got the SCO OpenServer Release 6.0.0 Maintenance Pack 4 Device Drivers Supplement .iso and installed the nd package. # mount -F cdfs /dev/cd0 /cd-rom # pkgadd -d /cd-rom Then elect the nd... (2 Replies)
Discussion started by: dalek
2 Replies

4. Solaris

Looking for Solaris 10 10/09 Drivers for these Devices

Could anyone tell me where I can obtain Solaris 10 10/09 drivers for these divices listed below. I have looked in the OpenSolaris forums but I have not had any luck. Device Vendor Device Name Network Atheros AR928X Wireless Network Adapter (PCI-Express) Storage Intel 82801 SATA... (4 Replies)
Discussion started by: Tenyhwa
4 Replies

5. UNIX for Dummies Questions & Answers

Help with ip search script

Hi Obviously first time poster here. I have been set the task of creating a network diagram for each of our clients in the business i work for. After identifying ip adresses of firewalls name servers and the like im got to the point where i found it impracticle to go through 254 ip address and... (6 Replies)
Discussion started by: jeked
6 Replies

6. UNIX for Advanced & Expert Users

Learn Linux File System and Device Drivers

I am to start working on two project on Linux Device Drivers and other on File System. So I got the book "Understanding Linux Kernel" by Daniel and Marco. But I am confused as how to proce Will anybody pls let me know how to go to about studying the chapter in this book? I mean the order in... (1 Reply)
Discussion started by: shefalibv
1 Replies

7. Shell Programming and Scripting

The -f switch is not identifying files[solved]

(1 Reply)
Discussion started by: lowExpectations
1 Replies