Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_mapmempage(9f) [sunos man page]

csx_MapMemPage(9F)					   Kernel Functions for Drivers 					csx_MapMemPage(9F)

NAME
csx_MapMemPage - map the memory area on a PC Card SYNOPSIS
#include <sys/pccard.h> int32_t csx_MapMemPage(window_handle_t wh, map_mem_page_t *mp); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
wh Window handle returned from csx_RequestWindow(9F). mp Pointer to a map_mem_page_t structure. DESCRIPTION
This function maps the memory area on a PC Card into a page of a window allocated with the csx_RequestWindow(9F) function. STRUCTURE MEMBERS
The structure members of map_mem_page_t are: uint32_t CardOffset; /* card offset */ uint32_t Page; /* page number */ The fields are defined as follows: CardOffset The absolute offset in bytes from the beginning of the PC Card to map into system memory. Page Used internally by Card Services; clients must set this field to 0 before calling this function. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_BAD_OFFSET Offset is invalid. CS_BAD_PAGE Page is not zero. CS_NO_CARD No PC Card in socket. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_ModifyWindow(9F), csx_ReleaseWindow(9F), csx_RequestWindow(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_MapMemPage(9F)

Check Out this Related Man Page

csx_ReleaseConfiguration(9F)				   Kernel Functions for Drivers 			      csx_ReleaseConfiguration(9F)

NAME
csx_ReleaseConfiguration - release PC Card and socket configuration SYNOPSIS
#include <sys/pccard.h> int32_t csx_ReleaseConfiguration(client_handle_t ch, release_config_t *rc); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). rc Pointer to a release_config_t structure. DESCRIPTION
This function returns a PC Card and socket to a simple memory only interface and sets the card to configuration zero by writing a 0 to the PC card's COR (Configuration Option Register). Card Services may remove power from the socket if no clients have indicated their usage of the socket by an active csx_RequestConfigura- tion(9F) or csx_RequestWindow(9F). Card Services is prohibited from resetting the PC Card and is not required to cycle power through zero(0) volts. After calling csx_ReleaseConfiguration() any resources requested via the request functions csx_RequestIO(9F), csx_RequestIRQ(9F), or csx_RequestWindow(9F) that are no longer needed should be returned to Card Services via the corresponding csx_ReleaseIO(9F), csx_Relea- seIRQ(9F), or csx_ReleaseWindow(9F) functions. csx_ReleaseConfiguration() must be called to release the current card and socket configura- tion before releasing any resources requested by the driver via the request functions named above. STRUCTURE MEMBERS
The structure members of release_config_t are: uint32_t Socket; /* socket number */ The Socket field is not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid or csx_RequestConfiguration(9F) not done. CS_BAD_SOCKET Error getting or setting socket hardware parameters. CS_NO_CARD No PC card in socket. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_RegisterClient(9F), csx_RequestConfiguration(9F), csx_RequestIO(9F), csx_RequestIRQ(9F), csx_RequestWindow(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 19 Jul 1996 csx_ReleaseConfiguration(9F)
Man Page