anocancel(9F) Kernel Functions for Drivers anocancel(9F)NAME
anocancel - prevent cancellation of asynchronous I/O request
SYNOPSIS
#include <sys/ddi.h>
#include <sys/sunddi.h>
int anocancel( );
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
anocancel() should be used by drivers that do not support canceling asynchronous I/O requests. anocancel() is passed as the driver cancel
routine parameter to aphysio(9F).
RETURN VALUES
anocancel() returns ENXIO.
SEE ALSO aread(9E), awrite(9E), aphysio(9F)
Writing Device Drivers
SunOS 5.10 9 Nov 1994 anocancel(9F)
Check Out this Related Man Page
aphysio(9F) Kernel Functions for Drivers aphysio(9F)NAME
aphysio - perform asynchronous physical I/O
SYNOPSIS
#include <sys/types.h>
#include <sys/buf.h>
#include <sys/uio.h>
#include <sys/aio_req.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>
int aphysio(int (*strat)(struct buf *), int (*cancel)(struct buf *), dev_t dev, int rw, void (*mincnt)(struct buf *), struct aio_req
*aio_reqp);
PARAMETERS
strat Pointer to device strategy routine.
cancel Pointer to driver cancel routine. Used to cancel a submitted request. The driver must pass the address of the function
anocancel(9F) because cancellation is not supported.
dev The device number.
rw Read/write flag. This is either B_READ when reading from the device or B_WRITE when writing to the device.
mincnt Routine which bounds the maximum transfer unit size.
aio_reqp Pointer to the aio_req(9S) structure which describes the user I/O request.
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
aphysio() performs asynchronous I/O operations between the device and the address space described by aio_reqp->aio_uio.
Prior to the start of the transfer, aphysio() verifies the requested operation is valid. It then locks the pages involved in the I/O
transfer so they can not be paged out. The device strategy routine, strat, is then called one or more times to perform the physical I/O
operations. aphysio() does not wait for each transfer to complete, but returns as soon as the necessary requests have been made.
aphysio() calls mincnt to bound the maximum transfer unit size to a sensible default for the device and the system. Drivers which do not
provide their own local mincnt routine should call aphysio() with
minphys(9F). minphys(9F) is the system mincnt routine. minphys(9F) ensures the transfer size does not exceed any system limits.
If a driver supplies a local mincnt routine, this routine should perform the following actions:
o If bp->b_bcount exceeds a device limit, set bp->b_bcount to a value supported by the device.
o Call minphys(9F) to ensure that the driver does not circumvent additional system limits.
RETURN VALUES
aphysio() returns:
0 Upon success.
non-zero Upon failure.
CONTEXT
aphysio() can be called from user context only.
SEE ALSO aread(9E), awrite(9E), strategy(9E), anocancel(9F), biodone(9F), biowait(9F), minphys(9F), physio(9F), aio_req(9S), buf(9S), uio(9S)
Writing Device Drivers
WARNINGS
It is the driver's responsibility to call biodone(9F) when the transfer is complete.
BUGS
Cancellation is not supported in this release. The address of the function anocancel(9F) must be used as the cancel argument.
SunOS 5.10 9 Nov 1994 aphysio(9F)
Hi, i have a file like this:
A1
kdfjdljfdkljfdlf
A2
lfjdlfkjddkjf
A3
***no hit***
A4
ldjfldjfdk
A5
***no hit***
A6
jldfjdlfjdlkfjd
I want to remove the lines "***no hit*** and their above line to get an output file like this: (11 Replies)
Not my story, but interesting enough to be worth posting here IMHO. (Original is here)
The following is the 500-mile email story in the form it originally appeared, in a post to sage-members on Sun, 24 Nov 2002.:
From trey@sage.org Fri Nov 29 18:00:49 2002
Date: Sun, 24 Nov 2002 21:03:02... (3 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
Hi gurus,
I have a weird requirement. I need to convert the number to english lecture.
I have 1.2 ....19 numbers
I need to convert to first second third fourth, fifth, sixth...
Is there any way convert it using unix command?
thanks in advance. (8 Replies)
Hi,
Humorous UNIX Commands shows a fun way of using echo and dc to sort of obfuscate a string.
% echo 'sasb3135071790101768542287578439snlbxq'|dc
GET A LIFE!
I am just wanting to know if there is a way to sort of use dc and echo to print out an obfuscated/garbled string instead... (3 Replies)
Hi All,
Having recently started a new job, a Data Center Migration in fact I have been tasked with looking at some of the older Solaris boxes when I came across this little gem.
nismas# uname -a
SunOS nismas 5.5.1 Generic_103640-27 sun4u sparc SUNW,Ultra-1
nismas# uptime
10:37am up 2900... (2 Replies)
For any SunOS 5.XX release, it appears prior to the "login:" prompt (as if a "uname" command is run).
Would anyone know where that initial display of SunOS release comes from upon a remote login and how I can stop if from displaying?
Thank you (4 Replies)
I am trying to remove each line in which $2 is FP or RFP. I believe the below will remove one instance but not both. Thank you :).
file
12
123 FP
11
10 RFP
awk
awk -F'\t' '
$2 != "FP"' file
desired output
12
11 (6 Replies)
Hi everybody,
Which Unix base OS have best performance for HOST virtualization?
I tested SmartOS but it needs another OS to connect remotely!
Thanks in advance. (11 Replies)
I have this file:
>ID1
AA
>ID2
TTTTTT
>ID-3
AAAAAAAAA
>ID4
TTTTTTGGAGATCAGTAGCAGATGACAG-GGGGG-TGCACCCC
Add I am trying to use this script to output sequences longer than 15 characters:
sed -r '/^>/N;{/^.{,15}$/d}'
The desire output would be this:
>ID4... (8 Replies)
Hi,
I am having contents in a file like below,
cat testfile
rpool/swap
rpool/swap14
rpool/swap2
rpool/swap3
I want to sort the above contents like,
rpool/swap
rpool/swap2
rpool/swap3
rpool/swap14
I have tried in this way, (7 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)