sunos man page for uwritec

Query: uwritec

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

uwritec(9F)						   Kernel Functions for Drivers 					       uwritec(9F)

NAME
uwritec - remove a character from a uio structure
SYNOPSIS
#include <sys/uio.h> int uwritec(uio_t *uio_p);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI)
PARAMETERS
uio_p Pointer to the uio(9S) structure
DESCRIPTION
uwritec() returns a character from the uio structure pointed to by uio_p and updates the uio structure. See uiomove(9F).
RETURN VALUES
The next character for processing is returned on success, and -1 is returned if uio is empty or if there is an error.
CONTEXT
uwritec() can be called from user or interrupt context.
SEE ALSO
uiomove(9F), ureadc(9F), iovec(9S), uio(9S) Writing Device Drivers SunOS 5.10 11 Apr 1991 uwritec(9F)
Related Man Pages
write(9e) - opensolaris
uwritec(9f) - opensolaris
write(9e) - sunos
ureadc(9f) - sunos
uio.h(3head) - sunos
Similar Topics in the Unix Linux Community
Delete lines with a word and their above lines
The 500 Mile Email
Merge and Sort tabular data from different text files
Best performance UNIX just for HOST Virtualization?
Sort only numbers within a string