sunos man page for usb_get_addr

Query: usb_get_addr

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

usb_get_addr(9F)					   Kernel Functions for Drivers 					  usb_get_addr(9F)

NAME
usb_get_addr - Retrieve device USB address
SYNOPSIS
#include <sys/usb/usba.h> int usb_get_addr(dev_info_t *dip);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
dip Pointer to the device's dev_info structure.
DESCRIPTION
The usb_get_addr() function returns the current USB bus address for debugging purposes. The returned address is unique for a specific USB bus, and may be replicated if multiple host controller instances are present on the system.
RETURN VALUES
On success: USB device address. On failure: returns 0. Fails if dip is NULL.
CONTEXT
May be called from user, kernel or interrupt context.
EXAMPLES
int usb_addr; usb_addr = usb_get_addr(dip);
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Evolving | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+
SEE ALSO
attributes(5), usb_pipe_open(9F) SunOS 5.10 Feb 9 2004 usb_get_addr(9F)
Related Man Pages
usb_get_addr(9f) - sunos
usb_get_current_frame_number(9f) - sunos
usb_pipe_get_max_bulk_transfer_size(9f) - sunos
usb_create_pm_components(9f) - opensolaris
usb_handle_remote_wakeup(9f) - opensolaris
Similar Topics in the Unix Linux Community
Sunray, Solaris, Webcams
Does Solaris Volume Manager support USB flash drives?