sunos man page for ureadc

Query: ureadc

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ureadc(9F)						   Kernel Functions for Drivers 						ureadc(9F)

NAME
ureadc - add character to a uio structure
SYNOPSIS
#include <sys/uio.h> #include <sys/types.h> int ureadc(int c, uio_t *uio_p);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
c The character added to the uio(9S) structure. uio_p Pointer to the uio(9S) structure.
DESCRIPTION
ureadc() transfers the character c into the address space of the uio(9S) structure pointed to by uio_p, and updates the uio structure as for uiomove(9F).
RETURN VALUES
0 is returned on success and EFAULT on failure.
CONTEXT
ureadc() can be called from user or interrupt context.
SEE ALSO
uiomove(9F), uwritec(9F), iovec(9S), uio(9S) Writing Device Drivers SunOS 5.10 11 Apr 1991 ureadc(9F)
Related Man Pages
read(9e) - opensolaris
ureadc(9f) - opensolaris
uwritec(9f) - opensolaris
uio(3head) - sunos
uio.h(3head) - opensolaris
Similar Topics in the Unix Linux Community
Delete lines with a word and their above lines
The 500 Mile Email
UNIX fun stuff - echo and dc - obfuscate/garble a string sort of
Once upon an uptime.
How do I remove or hide SunOS version/release from remote login prompt?