sunos man page for strrchr

Query: strrchr

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

strchr(9F)						   Kernel Functions for Drivers 						strchr(9F)

NAME
strchr, strrchr - find a character in a string
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> char *strchr(const char *str, int chr); char *strrchr(const char *str, int chr);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
str Pointer to a string to be searched. chr The character to search for.
DESCRIPTION
strchr() The strchr() function returns a pointer to the first occurrence of chr in the string pointed to by str. strrchr() The strrchr() function returns a pointer to the last occurrence of chr in the string pointed to by str.
RETURN VALUES
strchr() and strrchr() return a pointer to a character, or NULL, if the search fails.
CONTEXT
These functions can be called from user or interrupt context.
SEE ALSO
strcmp(9F) Writing Device Drivers SunOS 5.10 16 Aug 2002 strchr(9F)
Related Man Pages
strchr(3) - osx
strchr(3) - freebsd
strchr(3) - suse
strchrnul(3) - suse
strchr(3) - netbsd
Similar Topics in the Unix Linux Community
Matching 2 items in a string
Redirecting Terminal to Local Application!
Simple Problems to Solve!
Using boost in program created by g++
Memory fragmentation in a Linux settop box