Query: strncasecmp
OS: sunos
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
strcmp(9F) Kernel Functions for Drivers strcmp(9F)NAMEstrcmp, strcasecmp, strncasecmp, strncmp - compare two null-terminated strings.SYNOPSIS#include <sys/ddi.h> int strcmp(const char *s1, const char *s2); int strcasecmp(const char *s1, const char *s2); int strncasecmp(const char *s1, const char *s2, size_t n); int strncmp(const char *s1, const char *s2, size_t n);INTERFACE LEVELSolaris DDI specific (Solaris DDI).PARAMETERSs1, s2 Pointers to character strings. n Count of characters to be compared.DESCRIPTIONstrcmp() strcmp() returns 0 if the strings are the same, or the integer value of the expression (*s1 - *s2) for the last characters compared if they differ. strcasecmp(), strncasecmp() The strcasecmp() and strncasecmp() functions are case-insensitive versions of strcmp() and strncmp(), respectively, described in this sec- tion. They assume the ASCII character set and ignore differences in case when comparing lowercase and uppercase characters. strncmp() strncmp() returns 0 if the first n characters of s1 and s2 are the same, or (*s1 - *s2) for the last characters compared if they dif- fer.RETURN VALUESstrcmp() returns 0 if the strings are the same, or (*s1 - *s2) for the last characters compared if they differ. strcasecmp() and strncasecmp() return values in the same fashion as strcmp() and strncmp(), respectively. strncmp() returns 0 if the first n characters of strings are the same, or (*s1 - *s2) for the last characters compared if they differ.CONTEXTThese functions can be called from user or interrupt context.SEE ALSOWriting Device Drivers SunOS 5.10 1 Apr 1994 strcmp(9F)
Related Man Pages |
---|
strcmp(3) - mojave |
strncmp(3) - mojave |
strcmp(3) - freebsd |
strncmp(3) - osx |
strncasecmp(9f) - sunos |
Similar Topics in the Unix Linux Community |
---|
C snipet on char Pointers |
comparing two strings |
tr command |
Finding specific series of strings or characters |
Hidden strcmp in glibc |