sunos man page for strlen

Query: strlen

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

strlen(9F)						   Kernel Functions for Drivers 						strlen(9F)

NAME
strlen - determine the number of non-null bytes in a string
SYNOPSIS
#include <sys/ddi.h> size_t strlen(const char *s);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
s Pointer to a character string.
DESCRIPTION
strlen() returns the number of non-null bytes in the string argument s.
RETURN VALUES
strlen() returns the number of non-null bytes in s.
CONTEXT
strlen() can be called from user or interrupt context.
SEE ALSO
Writing Device Drivers SunOS 5.10 11 Apr 1991 strlen(9F)
Related Man Pages
strcpy(9f) - sunos
strlcat(9f) - sunos
strlcpy(9f) - sunos
strlen(3) - opendarwin
strlen(3) - minix
Similar Topics in the Unix Linux Community
Problems with Strlen
Problem with the strlen function in ksh
'strlen' of a constant string
strlen for UTF-8
PHP: declared variables, strlen vs isset