sunos man page for strchr

Query: strchr

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

strchr(9F)						   Kernel Functions for Drivers 						strchr(9F)

NAME
strchr, strrchr - find a character in a string
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> char *strchr(const char *str, int chr); char *strrchr(const char *str, int chr);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
str Pointer to a string to be searched. chr The character to search for.
DESCRIPTION
strchr() The strchr() function returns a pointer to the first occurrence of chr in the string pointed to by str. strrchr() The strrchr() function returns a pointer to the last occurrence of chr in the string pointed to by str.
RETURN VALUES
strchr() and strrchr() return a pointer to a character, or NULL, if the search fails.
CONTEXT
These functions can be called from user or interrupt context.
SEE ALSO
strcmp(9F) Writing Device Drivers SunOS 5.10 16 Aug 2002 strchr(9F)
Related Man Pages
strrchr(3) - mojave
strchrnul(3) - linux
strchr(3) - freebsd
strchrnul(3) - freebsd
strrchr(3) - freebsd
Similar Topics in the Unix Linux Community
Changing the way arguments are read from program
C first Script Question
C++ getline, parse and take first tokens by condition
How to create one's own pipe in one's own shell?
Format specifier for sscanf() in C