sunos man page for scsi_log

Query: scsi_log

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

scsi_log(9F)						   Kernel Functions for Drivers 					      scsi_log(9F)

NAME
scsi_log - display a SCSI-device-related message
SYNOPSIS
#include <sys/scsi/scsi.h> #include <sys/cmn_err.h> void scsi_log(dev_info_t *dip, char *drv_name, uint_t level, const char *fmt, ...);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
dip Pointer to the dev_info structure. drv_name String naming the device. level Error level. fmt Display format.
DESCRIPTION
scsi_log() is a utility function that displays a message via the cmn_err(9F) routine. The error levels that can be passed in to this func- tion are CE_PANIC, CE_WARN, CE_NOTE, CE_CONT, and SCSI_DEBUG. The last level is used to assist in displaying debug messages to the console only. drv_name is the short name by which this device is known; example disk driver names are sd and cmdk. If the dev_info_t pointer is NULL, then the drv_name will be used with no unit or long name. If the first character in format is: o An exclamation mark (!), the message goes only to the system buffer. o A caret (^), the message goes only to the console. o A question mark (?) and level is CE_CONT, the message is always sent to the system buffer, but is written to the console only when the system has been booted in verbose mode. See kernel(1M). If neither condition is met, the ? character has no effect and is simply ignored. All formatting conversions in use by cmn_err() also work with scsi_log().
CONTEXT
scsi_log() may be called from user or interrupt context.
SEE ALSO
kernel(1M), sd(7D), cmn_err(9F), scsi_errmsg(9F) Writing Device Drivers SunOS 5.10 18 Nov 2004 scsi_log(9F)
Related Man Pages
cmn_err(9f) - sunos
scsi_vu_errmsg(9f) - sunos
vcmn_err(9f) - sunos
zcmn_err(9f) - sunos
cmn_err(9f) - minix
Similar Topics in the Unix Linux Community
/dev not updated on usb device removal