Query: qunbufcall
OS: sunos
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
qunbufcall(9F) Kernel Functions for Drivers qunbufcall(9F)NAMEqunbufcall - cancel a pending qbufcall requestSYNOPSIS#include <sys/stream.h> #include <sys/ddi.h> void qunbufcall(queue_t *q, bufcall_id_t id);INTERFACE LEVELSolaris DDI specific (Solaris DDI).PARAMETERSq Pointer to STREAMS queue_t structure. id Identifier returned from qbufcall(9F)DESCRIPTIONqunbufcall() cancels a pending qbufcall() request. The argument id is a non-zero identifier of the request to be cancelled. id is returned from the qbufcall() function used to issue the cancel request. The qunbufcall() function is tailored to be used with the enhanced STREAMS framework interface which is based on the concept of perimeters. (See mt-streams(9F).) qunbufcall() returns when the bufcall has been cancelled or finished executing. The bufcall will be cancelled even if it is blocked at the perimeters associated with the queue. All outstanding timeouts and bufcalls must be cancelled before a driver close routine can block and before the close routine calls qprocsoff(9F).CONTEXTqunbufcall() can be called from user or interrupt context.SEE ALSOmt-streams(9F), qbufcall(9F), qtimeout(9F), quntimeout(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 17 Oct 2002 qunbufcall(9F)