Query: put
OS: sunos
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
put(9F) Kernel Functions for Drivers put(9F)NAMEput - call a STREAMS put procedureSYNOPSIS#include <sys/stream.h> #include <sys/ddi.h> void put(queue_t *q, mblk_t *mp);INTERFACE LEVELArchitecture independent level 1 (DDI/DKI).PARAMETERSq Pointer to a STREAMS queue. mp Pointer to message block being passed into queue.DESCRIPTIONput() calls the put procedure ( put(9E) entry point) for the STREAMS queue specified by q, passing it the message block referred to by mp. It is typically used by a driver or module to call its own put procedure.CONTEXTput() can be called from a STREAMS module or driver put or service routine, or from an associated interrupt handler, timeout, bufcall, or esballoc call-back. In the latter cases, the calling code must guarantee the validity of the q argument. Since put() may cause re-entry of the module (as it is intended to do), mutexes or other locks should not be held across calls to it, due to the risk of single-party deadlock (put(9E), putnext(9F), putctl(9F), qreply(9F)). This function is provided as a DDI/DKI conforming replacement for a direct call to a put procedure.SEE ALSOput(9E), freezestr(9F), putctl(9F), putctl1(9F), putnext(9F), putnextctl(9F), putnextctl1(9F), qprocson(9F), qreply(9F) Writing Device Drivers STREAMS Programming GuideNOTESThe caller cannot have the stream frozen when calling this function. See freezestr(9F). DDI/DKI conforming modules and drivers are no longer permitted to call put procedures directly, but must call through the appropriate STREAMS utility function, for example, put(9E), putnext(9F), putctl(9F), and qreply(9F). This function is provided as a DDI/DKI conforming replacement for a direct call to a put procedure. The put() and putnext() functions should be called only after qprocson() is finished. SunOS 5.10 28 Apr 1992 put(9F)
Related Man Pages |
---|
put(9f) - opensolaris |
qprocsoff(9f) - sunos |
qprocson(9f) - debian |
qprocsoff(9f) - centos |
qprocson(9f) - php |
Similar Topics in the Unix Linux Community |
---|
VI Macro Problem |
DNS forwards |
passing strings as arguments |
place to put statup scripts? |
Procedure to restrict direct access as root |