Query: nvlist_remove_all
OS: sunos
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
nvlist_remove(9F) Kernel Functions for Drivers nvlist_remove(9F)NAMEnvlist_remove, nvlist_remove_all - remove name-value pairsSYNOPSIS#include <sys/nvpair.h> int nvlist_remove(nvlist_t *nvl, const char *name, data_type_t type); int nvlist_remove_all(nvlist_t *nvl, const char *name);INTERFACE LEVELSolaris DDI specific (Solaris DDI)PARAMETERSnvl The list of name-value pairs (nvlist_t) to be processed. name Name of the name-value pair (nvpair) to be removed. type Data type of the nvpair to be removed.DESCRIPTIONThe nvlist_remove() function removes the first occurrence of nvpair that matches the name and the type. The nvlist_remove_all() function removes all occurrences of nvpair that match the name, regardless of type. Multiple threads can simultaneously read the same nvlist_t but only one thread may actively change a given nvlist_t at a time. The caller is responsible for the synchronization.RETURN VALUESThese functions return 0 on success and an error value on failure.CONTEXTThe nvlist_remove() and nvlist_remove_all() functions can be called from user or interrupt context.ERRORSEINVAL There is an invalid argument. ENOENT No name-value pairs were found to match the criteria specified by name and type. SunOS 5.10 2 Feb 2004 nvlist_remove(9F)
Related Man Pages |
---|
nvlist_add_boolean_value(9f) - sunos |
nvpair_name(9f) - sunos |
nvlist_next_nvpair(9f) - opensolaris |
nvlist_remove_all(9f) - opensolaris |
nvpair_name(9f) - opensolaris |
Similar Topics in the Unix Linux Community |
---|
The 500 Mile Email |
Is UNIX an open source OS ? |
UNIX fun stuff - echo and dc - obfuscate/garble a string sort of |
Once upon an uptime. |
Best performance UNIX just for HOST Virtualization? |