sunos man page for noenable

Query: noenable

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

noenable(9F)						   Kernel Functions for Drivers 					      noenable(9F)

NAME
noenable - prevent a queue from being scheduled
SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> void noenable(queue_t *q);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Pointer to the queue.
DESCRIPTION
noenable() prevents the queue q from being scheduled for service by insq(9F), putq(9F) or putbq(9F) when enqueuing an ordinary priority message. The queue can be re-enabled with the enableok(9F) function.
CONTEXT
noenable() can be called from user or interrupt context.
SEE ALSO
enableok(9F), insq(9F), putbq(9F), putq(9F), qenable(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 noenable(9F)
Related Man Pages
enableok(9f) - opensolaris
noenable(9f) - opensolaris
putq(9f) - debian
putq(9f) - php
putq(9f) - opendarwin
Similar Topics in the Unix Linux Community
The 500 Mile Email
How to convert number to english?
Merge and Sort tabular data from different text files
Outputting sequences based on length with sed
Sort only numbers within a string