sunos man page for ldi_get_eventcookie

Query: ldi_get_eventcookie

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ldi_get_eventcookie(9F) 				   Kernel Functions for Drivers 				   ldi_get_eventcookie(9F)

NAME
ldi_get_eventcookie - Retrieve an NDI event service cookie for the device represented by the layered driver handle
SYNOPSIS
#include <sys/sunldi.h> int ldi_get_eventcookie(ldi_handle_t lh, char *name ddi_eventcookie_t * ecp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
ldi_handle_t lh Layered handle. char *name NULL-terminated string containing the event name. ddi_eventcookie_t *ecp Pointer to the kernel event cookie.
DESCRIPTION
The ldi_get_eventcookie() function queries the device tree for a cookie matching the given event name and returns a reference to that cookie. The search is performed by calling up the device tree hierarchy of the device represented by the layered driver handle until the request is satisfied by a bus nexus driver, or the top of the dev_info tree is reached. The cookie returned by this function can be used to register a callback handler with ldi_add_event_handler(9F).
RETURN VALUES
DDI_SUCCESS Cookie handle is returned. DDI_FAILURE Request was not serviceable by any nexus driver in the target device's ancestral device tree hierarchy.
CONTEXT
This function may be called from user or kernel contexts.
SEE ALSO
ldi_add_event_handler(9F), ldi_remove_event_handler(9F) Writing Device Drivers SunOS 5.10 9 Feb 2004 ldi_get_eventcookie(9F)
Related Man Pages
ldi_prop_get_int64(9f) - sunos
ddi_get_eventcookie(9f) - sunos
ldi_add_event_handler(9f) - sunos
ddi_add_event_handler(9f) - opensolaris
ldi_get_eventcookie(9f) - opensolaris
Similar Topics in the Unix Linux Community
cp without maintaining the soucre directory tree hierarchy
vi Search for text, Replace with &lt;CR&gt; or control character.