sunos man page for freemsg

Query: freemsg

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

freemsg(9F)						   Kernel Functions for Drivers 					       freemsg(9F)

NAME
freemsg - free all message blocks in a message
SYNOPSIS
#include <sys/stream.h> void freemsg(mblk_t *mp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
mp Pointer to the message blocks to be deallocated. mblk_t is an instance of the msgb(9S) structure. If mp is NULL, freemsg() imme- diately returns.
DESCRIPTION
freemsg() calls freeb(9F) to free all message and data blocks associated with the message pointed to by mp.
CONTEXT
freemsg() can be called from user or interrupt context.
EXAMPLES
Example 1: Using freemsg() See copymsg(9F).
SEE ALSO
copymsg(9F), freeb(9F), msgb(9S) Writing Device Drivers STREAMS Programming Guide
NOTES
The behavior of freemsg() when passed a NULL pointer is Solaris-specific. SunOS 5.10 26 Oct 2001 freemsg(9F)
Related Man Pages
freemsg(9f) - debian
freemsg(9f) - centos
freemsg(9f) - minix
freemsg(9f) - osx
freemsg(9f) - redhat
Similar Topics in the Unix Linux Community
Delete lines with a word and their above lines
The 500 Mile Email
Is UNIX an open source OS ?
Merge and Sort tabular data from different text files
Outputting sequences based on length with sed