sunos man page for devmap_set_ctx_timeout

Query: devmap_set_ctx_timeout

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

devmap_set_ctx_timeout(9F)				   Kernel Functions for Drivers 				devmap_set_ctx_timeout(9F)

NAME
devmap_set_ctx_timeout - set the timeout value for the context management callback
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> void devmap_set_ctx_timeout(devmap_cookie_t dhp, clock_t ticks);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
dhp An opaque mapping handle that the system uses to describe the mapping. ticks Number of clock ticks to wait between successive calls to the context management callback function.
DESCRIPTION
devmap_set_ctx_timeout() specifies the time interval for the system to wait between successive calls to the driver's context management callback function, devmap_contextmgt(9E). Device drivers typically call devmap_set_ctx_timeout() in the devmap_map(9E) routine. If the drivers do not call devmap_set_ctx_timeout() to set the timeout value, the default timeout value of 0 will result in no delay between successive calls to the driver's devmap_con- textmgt(9E) callback function.
CONTEXT
devmap_set_ctx_timeout() can be called from user or interrupt context.
SEE ALSO
devmap_contextmgt(9E), devmap_map(9E), timeout(9F) SunOS 5.10 22 Jan 1997 devmap_set_ctx_timeout(9F)
Related Man Pages
devmap_do_ctxmgt(9f) - opensolaris
devmap_contextmgt(9e) - opensolaris
devmap_do_ctxmgt(9f) - posix
devmap_contextmgt(9e) - centos
devmap_do_ctxmgt(9f) - php
Similar Topics in the Unix Linux Community
Delete lines with a word and their above lines
Is UNIX an open source OS ?
Merge and Sort tabular data from different text files
Best performance UNIX just for HOST Virtualization?
Sort only numbers within a string