sunos man page for ddi_slaveonly

Query: ddi_slaveonly

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_slaveonly(9F)					   Kernel Functions for Drivers 					 ddi_slaveonly(9F)

NAME
ddi_slaveonly - tell if a device is installed in a slave access only location
SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_slaveonly(dev_info_t *dip);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
dip A pointer to the device's dev_info structure.
DESCRIPTION
ddi_slaveonly() tells the caller if the bus, or part of the bus that the device is installed on, does not permit the device to become a DMA master, that is, whether the device has been installed in a slave access only slot.
RETURN VALUES
DDI_SUCCESS The device has been installed in a slave access only location. DDI_FAILURE The device has not been installed in a slave access only location.
CONTEXT
ddi_slaveonly() can be called from user or interrupt context.
SEE ALSO
Writing Device Drivers SunOS 5.10 24 Oct 1991 ddi_slaveonly(9F)
Related Man Pages
ddi_dev_is_sid(9f) - sunos
ddi_dev_is_sid(9f) - v7
ddi_dev_is_sid(9f) - bsd
ddi_dev_is_sid(9f) - linux
ddi_dev_is_sid(9f) - plan9
Similar Topics in the Unix Linux Community
Delete lines with a word and their above lines
Is UNIX an open source OS ?
Merge and Sort tabular data from different text files
Using awk to remove lines from file that match text
Outputting sequences based on length with sed