Query: ddi_mem_put32
OS: sunos
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
ddi_mem_put8(9F) Kernel Functions for Drivers ddi_mem_put8(9F)NAMEddi_mem_put8, ddi_mem_put16, ddi_mem_put32, ddi_mem_put64, ddi_mem_putb, ddi_mem_putw, ddi_mem_putl, ddi_mem_putll - write data to mapped device in the memory space or allocated DMA memorySYNOPSIS#include <sys/ddi.h> #include <sys/sunddi.h> void ddi_mem_put8(ddi_acc_handle_t handle, uint8_t *dev_addr, uint8_t value); void ddi_mem_put16(ddi_acc_handle_t handle, uint16_t *dev_addr, uint16_t value); void ddi_mem_put32(ddi_acc_handle_t handle, uint32_t *dev_addr, uint32_t value); void ddi_mem_put64(ddi_acc_handle_t handle, uint64_t *dev_addr, uint64_t value);PARAMETERShandle The data access handle returned from setup calls, such as ddi_regs_map_setup(9F). dev_addr Base device address. value The data to be written to the device.INTERFACE LEVELSolaris DDI specific (Solaris DDI).DESCRIPTIONThese routines generate a write of various sizes to memory space or allocated DMA memory. The ddi_mem_put8(), ddi_mem_put16(), ddi_mem_put32(), and ddi_mem_put64() functions write 8 bits, 16 bits, 32 bits and 64 bits of data, respectively, to the device address, dev_addr, in memory space. Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle. The translation may involve byte-swapping if the host and the device have incompatible endian char- acteristics.CONTEXTThese functions can be called from user, kernel, or interrupt context.SEE ALSOddi_mem_get8(9F), ddi_mem_rep_get8(9F), ddi_regs_map_setup(9F), ddi_device_acc_attr(9S)NOTESThe functions described in this manual page previously used symbolic names which specified their data access size; the function names have been changed so they now specify a fixed-width data size. See the following table for the new name equivalents: +-----------------------------------------------------------+ |Previous Name New Name | |ddi_mem_putb ddi_mem_put8 | |ddi_mem_putw ddi_mem_put16 | |ddi_mem_putl ddi_mem_put32 | |ddi_mem_putll ddi_mem_put64 | +-----------------------------------------------------------+ SunOS 5.10 28 Sep 1996 ddi_mem_put8(9F)
Related Man Pages |
---|
ddi_mem_put32(9f) - sunos |
ddi_mem_put64(9f) - sunos |
ddi_mem_putl(9f) - sunos |
ddi_mem_putb(9f) - sunos |
ddi_mem_putll(9f) - sunos |
Similar Topics in the Unix Linux Community |
---|
The 500 Mile Email |
Is UNIX an open source OS ? |
How to convert number to english? |
Once upon an uptime. |
Best performance UNIX just for HOST Virtualization? |