sunos man page for ddi_mem_get64

Query: ddi_mem_get64

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_mem_get8(9F)					   Kernel Functions for Drivers 					  ddi_mem_get8(9F)

NAME
ddi_mem_get8, ddi_mem_get16, ddi_mem_get32, ddi_mem_get64, ddi_mem_getw, ddi_mem_getl, ddi_mem_getll, ddi_mem_getb - read data from mapped device in the memory space or allocated DMA memory
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> uint8_t ddi_mem_get8(ddi_acc_handle_t handle, uint8_t *dev_addr); uint16_t ddi_mem_get16(ddi_acc_handle_t handle, uint16_t * dev_addr); uint32_t ddi_mem_get32(ddi_acc_handle_t handle, uint32_t *dev_addr); uint64_t ddi_mem_get64(ddi_acc_handle_t handle, uint64_t *dev_addr);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
handle The data access handle returned from setup calls, such as ddi_regs_map_setup(9F). dev_addr Base device address.
DESCRIPTION
These routines generate a read of various sizes from memory space or allocated DMA memory. The ddi_mem_get8(), ddi_mem_get16(), ddi_mem_get32(), and ddi_mem_get64() functions read 8 bits, 16 bits, 32 bits and 64 bits of data, respectively, from the device address, dev_addr, in memory space. Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle. The translation may involve byte-swapping if the host and the device have incompatible endian char- acteristics.
CONTEXT
These functions can be called from user, kernel, or interrupt context.
SEE ALSO
ddi_mem_put8(9F), ddi_mem_rep_get8(9F), ddi_mem_rep_put8(9F), ddi_regs_map_setup(9F), ddi_device_acc_attr(9S)
NOTES
The functions described in this manual page previously used symbolic names which specified their data access size; the function names have been changed so they now specify a fixed-width data size. See the following table for the new name equivalents: +-----------------------------------------------------------+ |Previous Name New Name | |ddi_mem_getb ddi_mem_get8 | |ddi_mem_getw ddi_mem_get16 | |ddi_mem_getl ddi_mem_get32 | |ddi_mem_getll ddi_mem_get64 | +-----------------------------------------------------------+ SunOS 5.10 30 Sep 1996 ddi_mem_get8(9F)
Related Man Pages
ddi_mem_get16(9f) - sunos
ddi_mem_get8(9f) - sunos
ddi_mem_getw(9f) - sunos
ddi_mem_get8(9f) - opensolaris
ddi_mem_get64(9f) - opensolaris
Similar Topics in the Unix Linux Community
How to convert number to english?
Merge and Sort tabular data from different text files
Using awk to remove lines from file that match text
Outputting sequences based on length with sed
UNIX Environment Setup - (Just starting!)