Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_io_rep_get32(9f) [sunos man page]

ddi_io_rep_get8(9F)					   Kernel Functions for Drivers 				       ddi_io_rep_get8(9F)

NAME
ddi_io_rep_get8, ddi_io_rep_get16, ddi_io_rep_get32, ddi_io_rep_getw, ddi_io_rep_getb, ddi_io_rep_getl - read multiple data from the mapped device register in I/O space SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> void ddi_io_rep_get8(ddi_acc_handle_t handle, uint8_t *host_addr, uint8_t *dev_addr,, size_t repcount); void ddi_io_rep_get16(ddi_acc_handle_t handle, uint16_t *host_addr, uint16_t *dev_addr,, size_t repcount); void ddi_io_rep_get32(ddi_acc_handle_t handle, uint32_t *host_addr, uint32_t *dev_addr,, size_t repcount); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
handle The data access handle returned from setup calls, such as ddi_regs_map_setup(9F). host_addr Base host address. dev_addr Base device address. repcount Number of data accesses to perform. DESCRIPTION
These routines generate multiple reads from the device address, dev_addr, in I/O space. repcount data is copied from the device address, dev_addr, to the host address, host_addr. For each input datum, the ddi_io_rep_get8(), ddi_io_rep_get16(), and ddi_io_rep_get32() functions read 8 bits, 16 bits, and 32 bits of data, respectively, from the device address. host_addr must be aligned to the datum boundary described by the function. Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle. The translation may involve byte-swapping if the host and the device have incompatible endian char- acteristics. CONTEXT
These functions can be called from user, kernel, or interrupt context. SEE ALSO
isa(4), ddi_io_get8(9F), ddi_io_put8(9F), ddi_io_rep_put8(9F), ddi_regs_map_free(9F), ddi_regs_map_setup(9F), ddi_device_acc_attr(9S) NOTES
For drivers using these functions, it may not be easy to maintain a single source to support devices with multiple bus versions. For exam- ple, devices may offer I/O space in ISA bus (see isa(4)) but memory space only in PCI local bus. This is especially true in instruction set architectures such as x86 where accesses to the memory and I/O space are different. The functions described in this manual page previously used symbolic names which specified their data access size; the function names have been changed so they now specify a fixed-width data size. See the following table for the new name equivalents: +-----------------------------------------------------------+ |Previous Name New Name | |ddi_io_rep_getb ddi_io_rep_get8 | |ddi_io_rep_getw ddi_io_rep_get16 | |ddi_io_rep_getl ddi_io_rep_get32 | +-----------------------------------------------------------+ SunOS 5.10 29 June 1999 ddi_io_rep_get8(9F)

Check Out this Related Man Page

ddi_io_rep_get8(9F)					   Kernel Functions for Drivers 				       ddi_io_rep_get8(9F)

NAME
ddi_io_rep_get8, ddi_io_rep_get16, ddi_io_rep_get32, ddi_io_rep_getb, ddi_io_rep_getl, ddi_io_rep_getw - read multiple data from the mapped device register in I/O space SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> void ddi_io_rep_get8(ddi_acc_handle_t handle, uint8_t *host_addr, uint8_t *dev_addr, size_t repcount); void ddi_io_rep_get16(ddi_acc_handle_t handle, uint16_t *host_addr, uint16_t *dev_addr,, size_t repcount); void ddi_io_rep_get32(ddi_acc_handle_t handle, uint32_t *host_addr, uint32_t *dev_addr,, size_t repcount); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). The ddi_io_rep_get8(), ddi_io_rep_get16(), ddi_io_rep_get32(), ddi_io_rep_getb(), ddi_io_rep_getl(), and ddi_io_rep_getw() functions are obsolete. The ddi_rep_get8(9F) function replaces ddi_io_rep_get8(). The ddi_rep_get16(9F) function replaces ddi_io_rep_get16(). The ddi_rep_get32(9F) function replaces ddi_io_rep_get32(). The ddi_rep_get8(9F) function replaces ddi_io_rep_getb(). The ddi_rep_get32(9F) function replaces ddi_io_rep_getl(). The ddi_rep_get16(9F) function replaces ddi_io_rep_getw(). PARAMETERS
handle The data access handle returned from setup calls, such as ddi_regs_map_setup(9F). host_addr Base host address. dev_addr Base device address. repcount Number of data accesses to perform. DESCRIPTION
These routines generate multiple reads from the device address, dev_addr, in I/O space. repcount data is copied from the device address, dev_addr, to the host address, host_addr. For each input datum, the ddi_io_rep_get8(), ddi_io_rep_get16(), and ddi_io_rep_get32() functions read 8 bits, 16 bits, and 32 bits of data, respectively, from the device address. host_addr must be aligned to the datum boundary described by the function. Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle. The translation may involve byte-swapping if the host and the device have incompatible endian char- acteristics. CONTEXT
These functions can be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Obsolete | +-----------------------------+-----------------------------+ SEE ALSO
isa(4), ddi_io_get8(9F), ddi_io_put8(9F), ddi_io_rep_put8(9F), ddi_regs_map_free(9F), ddi_regs_map_setup(9F), ddi_rep_get8(9F), ddi_rep_get16(9F), ddi_rep_get32(9F), ddi_device_acc_attr(9S) SunOS 5.11 1 Nov 2005 ddi_io_rep_get8(9F)
Man Page