sunos man page for ddi_getiminor

Query: ddi_getiminor

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_getiminor(9F)					   Kernel Functions for Drivers 					 ddi_getiminor(9F)

NAME
ddi_getiminor - get kernel internal minor number from an external dev_t
SYNOPSIS
#include <sys/types.h> #include <sys/mkdev.h> #include <sys/ddi.h> minor_t ddi_getiminor(dev_t dev); INTERFACE LEVEL This interface is obsolete. getminor(9F) should be used instead.
PARAMETERS
The following parameters are supported: dev Device number.
DESCRIPTION
ddi_getiminor() extracts the minor number from a device number. This call should be used only for device numbers that have been passed to the kernel from the user space through opaque interfaces such as the contents of ioctl(9E) and putmsg(2). The device numbers passed in using standard device entry points must continue to be interpreted using the getminor(9F) interface. This new interface is used to trans- late between user visible device numbers and in kernel device numbers. The two numbers may differ in a clustered system. For certain bus types, you can call this DDI function from a high-interrupt context. These types include ISA and SBus buses. See sys- bus(4), isa(4), and sbus(4) for details.
CONTEXT
ddi_getiminor() can be called from user context only.
RETURN VALUES
The minor number or EMINOR_UNKNOWN if the minor number of the device is invalid.
ATTRIBUTES
See attributes(5) for a description of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Stability Level |Obsolete | +-----------------------------+-----------------------------+
SEE ALSO
attributes(5), getmajor(9F), getminor(9F), makedevice(9F) Writing Device Drivers
WARNINGS
Drivers are required to replace calls to ddi_getminor.9f by getminor(9F)) in order to compile under Solaris 10 and later versions. SunOS 5.10 18 Nov 2004 ddi_getiminor(9F)
Related Man Pages
di_minor_nodetype(3devinfo) - opensolaris
ddi_getiminor(9f) - sunos
ddi_getiminor(9f) - opensolaris
di_minor_devt(3devinfo) - minix
di_minor_devt(3devinfo) - suse
Similar Topics in the Unix Linux Community
The 500 Mile Email
How to convert number to english?
Using awk to remove lines from file that match text
Best performance UNIX just for HOST Virtualization?
Outputting sequences based on length with sed