sunos man page for ddi_get32

Query: ddi_get32

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_get8(9F)						   Kernel Functions for Drivers 					      ddi_get8(9F)

NAME
ddi_get8, ddi_get16, ddi_get32, ddi_get64, ddi_getb, ddi_getw, ddi_getl, ddi_getll - read data from the mapped memory address, device reg- ister or allocated DMA memory address
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> uint8_t ddi_get8(ddi_acc_handle_t handle, uint8_t *dev_addr); uint16_t ddi_get16(ddi_acc_handle_t handle, uint16_t *dev_addr); uint32_t ddi_get32(ddi_acc_handle_t handle, uint32_t *dev_addr); uint64_t ddi_get64(ddi_acc_handle_t handle, uint64_t *dev_addr);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
handle The data access handle returned from setup calls, such as ddi_regs_map_setup(9F). dev_addr Base device address.
DESCRIPTION
The ddi_get8(), ddi_get16(), ddi_get32(), and ddi_get64() functions read 8 bits, 16 bits, 32 bits and 64 bits of data, respectively, from the device address, dev_addr. Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle. The translation may involve byte-swapping if the host and the device have incompatible endian char- acteristics. For certain bus types, you can call these DDI functions from a high-interrupt context. These types include ISA and SBus buses. See sys- bus(4), isa(4), and sbus(4) for details. For the PCI bus, you can, under certain conditions, call these DDI functions from a high-interrupt context. See pci(4).
RETURN VALUES
These functions return the value read from the mapped address.
CONTEXT
These functions can be called from user, kernel, or interrupt context.
SEE ALSO
ddi_put8(9F), ddi_regs_map_free(9F), ddi_regs_map_setup(9F), ddi_rep_get8(9F), ddi_rep_put8(9F)
NOTES
The functions described in this manual page previously used symbolic names which specified their data access size; the function names have been changed so they now specify a fixed-width data size. See the following table for the new name equivalents: +--------------------------------------------------------------+ |Previous Name New Name | |ddi_getb ddi_get8 | |ddi_getw ddi_get16 | |ddi_getl ddi_get32 | |ddi_getll ddi_get64 | +--------------------------------------------------------------+ SunOS 5.10 18 Nov 2004 ddi_get8(9F)
Related Man Pages
ddi_get64(9f) - sunos
ddi_getb(9f) - sunos
ddi_getl(9f) - sunos
ddi_getll(9f) - sunos
ddi_get8(9f) - php
Similar Topics in the Unix Linux Community
The 500 Mile Email
Is UNIX an open source OS ?
UNIX fun stuff - echo and dc - obfuscate/garble a string sort of
Merge and Sort tabular data from different text files
Sort only numbers within a string