sunos man page for ddi_dma_get_attr

Query: ddi_dma_get_attr

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_dma_get_attr(9F)					   Kernel Functions for Drivers 				      ddi_dma_get_attr(9F)

NAME
ddi_dma_get_attr - get the device DMA attribute structure from a DMA handle
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_get_attr(ddi_dma_handle_t handle, ddi_dma_attr_t *attrp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
handle The handle filled in by a call to ddi_dma_alloc_handle(9F). attrp Pointer to a buffer suitable for holding a DMA attribute structure. See ddi_dma_attr(9S).
DESCRIPTION
ddi_dma_get_attr() is used to get a ddi_dma_attr(9S) structure. This structure describes the attributes of the DMA data path to which any memory object bound to the given handle will be subject.
RETURN VALUES
DDI_SUCCESS Successfully passed back attribute structure in buffer pointed to by attrp. DDI_DMA_BADATTR A valid attribute structure could not be passed back.
CONTEXT
ddi_dma_get_attr() can be called from any context.
SEE ALSO
ddi_dma_alloc_handle(9F), ddi_dma_attr(9S) SunOS 5.10 29 August 2000 ddi_dma_get_attr(9F)
Related Man Pages
ddi_dma_alloc_handle(9f) - opensolaris
ddi_dma_alloc_handle(9f) - centos
ddi_dma_alloc_handle(9f) - xfree86
ddi_dma_alloc_handle(9f) - hpux
ddi_dma_alloc_handle(9f) - posix
Similar Topics in the Unix Linux Community
How to convert number to english?
Merge and Sort tabular data from different text files
Once upon an uptime.
Best performance UNIX just for HOST Virtualization?
UNIX Environment Setup - (Just starting!)