Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_get64(9f) [sunos man page]

csx_Get8(9F)						   Kernel Functions for Drivers 					      csx_Get8(9F)

NAME
csx_Get8, csx_Get16, csx_Get32, csx_Get64 - read data from device address SYNOPSIS
#include <sys/pccard.h> uint8_t csx_Get8(acc_handle_t handle, uint32_t offset); uint16_t csx_Get16(acc_handle_t handle, uint32_t offset); uint32_t csx_Get32(acc_handle_t handle, uint32_t offset); uint64_t csx_Get64(acc_handle_t handle, uint64_t offset); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
handle The access handle returned from csx_RequestIO(9F), csx_RequestWindow(9F), or csx_DupHandle(9F). offset The offset in bytes from the base of the mapped resource. DESCRIPTION
These functions generate a read of various sizes from the mapped memory or device register. The csx_Get8(), csx_Get16(), csx_Get32(), and csx_Get64() functions read 8 bits, 16 bits, 32 bits, and 64 bits of data, respectively, from the device address represented by the handle, handle, at an offset in bytes represented by the offset, offset. Data that consists of more than one byte will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle. The translation may involve byte swapping if the host and the device have incompatible endian characteristics. RETURN VALUES
These functions return the value read from the mapped address. CONTEXT
These functions may be called from user, kernel, or interrupt context. SEE ALSO
csx_DupHandle(9F), csx_GetMappedAddr(9F), csx_Put8(9F), csx_RepGet8(9F), csx_RepPut8(9F), csx_RequestIO(9F), csx_RequestWindow(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_Get8(9F)

Check Out this Related Man Page

csx_RepGet8(9F) 					   Kernel Functions for Drivers 					   csx_RepGet8(9F)

NAME
csx_RepGet8, csx_RepGet16, csx_RepGet32, csx_RepGet64 - read repetitively from the device register SYNOPSIS
#include <sys/pccard.h> void csx_RepGet8(acc_handle_t handle, uint8_t *hostaddr, uint32_t offset, uint32_t repcount, uint32_t flags); void csx_RepGet16(acc_handle_t handle, uint16_t *hostaddr, uint32_t offset, uint32_t repcount, uint32_t flags); void csx_RepGet32(acc_handle_t handle, uint32_t *hostaddr, uint32_t offset, uint32_t repcount, uint32_t flags); void csx_RepGet64(acc_handle_t handle, uint64_t *hostaddr, uint32_t offset, uint32_t repcount, uint32_t flags); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
handle The access handle returned from csx_RequestIO(9F), csx_RequestWindow(9F), or csx_DupHandle(9F). hostaddr Source host address. offset The offset in bytes from the base of the mapped resource. repcount Number of data accesses to perform. flags Device address flags. DESCRIPTION
These functions generate multiple reads of various sizes from the mapped memory or device register. The csx_RepGet8(), csx_RepGet16(), csx_RepGet32(), and csx_RepGet64() functions generate repcount reads of 8 bits, 16 bits, 32 bits, and 64 bits of data, respectively, from the device address represented by the handle, handle, at an offset in bytes represented by the offset, offset. The data read is stored consecutively into the buffer pointed to by the host address pointer, hostaddr. Data that consists of more than one byte will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle. The translation may involve byte swapping if the host and the device have incompatible endian characteristics. When the flags argument is set to CS_DEV_AUTOINCR, these functions increment the device offset, offset, after each datum read operation. However, when the flags argument is set to CS_DEV_NO_AUTOINCR, the same device offset will be used for every datum access. For example, this flag may be useful when reading from a data register. CONTEXT
These functions may be called from user, kernel, or interrupt context. SEE ALSO
csx_DupHandle(9F), csx_Get8(9F), csx_GetMappedAddr(9F), csx_Put8(9F), csx_RepPut8(9F), csx_RequestIO(9F), csx_RequestWindow(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 19 Jul 1996 csx_RepGet8(9F)
Man Page