sunos man page for bcmp

Query: bcmp

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

bcmp(9F)						   Kernel Functions for Drivers 						  bcmp(9F)

NAME
bcmp - compare two byte arrays
SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> int bcmp(const void *s1, const void *s2, size_t len);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
s1 Pointer to the first character string. s2 Pointer to the second character string. len Number of bytes to be compared.
DESCRIPTION
bcmp() compares two byte arrays of length len.
RETURN VALUES
bcmp() returns 0 if the arrays are identical, or 1 if they are not.
CONTEXT
bcmp() can be called from user or interrupt context.
SEE ALSO
strcmp(9F) Writing Device Drivers
NOTES
Unlike strcmp(9F), bcmp() does not terminate when it encounters a null byte. SunOS 5.10 1 May 1996 bcmp(9F)
Related Man Pages
bcmp(3) - centos
bcmp(3) - osf1
bcopy(3) - osf1
bcmp(3) - minix
bcmp(3) - php
Similar Topics in the Unix Linux Community
[spam] FAXmaker- Fax Server for Windows NT/2000
Unix gurus : how to grep this pattern?
Explanation reqd for the Unix file
Not able to find the perfect code...Geting confused in between
A script need help