sunos man page for backq

Query: backq

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

backq(9F)						   Kernel Functions for Drivers 						 backq(9F)

NAME
backq - get pointer to the queue behind the current queue
SYNOPSIS
#include <sys/stream.h> queue_t *backq(queue_t *cq);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
cq The pointer to the current queue. queue_t is an alias for the queue(9S) structure.
DESCRIPTION
backq() returns a pointer to the queue preceding cq (the current queue). If cq is a read queue, backq() returns a pointer to the queue downstream from cq, unless it is the stream end. If cq is a write queue, backq() returns a pointer to the next queue upstream from cq, unless it is the stream head.
RETURN VALUES
If successful, backq() returns a pointer to the queue preceding the current queue. Otherwise, it returns NULL.
CONTEXT
backq() can be called from user or interrupt context.
SEE ALSO
queue(9S) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 backq(9F)
Related Man Pages
wr(9f) - sunos
rd(9f) - osx
wr(9f) - centos
wr(9f) - linux
wr(9f) - mojave
Similar Topics in the Unix Linux Community
perl scalar variable in backquoted string
awk field not recognized in backquotes
variable redirect messing up a sed command.
how to print a backquote in csh
Remove backquotes from file