sunos man page for allocb_tmpl

Query: allocb_tmpl

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

allocb_tmpl(9F) 					   Kernel Functions for Drivers 					   allocb_tmpl(9F)

NAME
allocb_tmpl - allocate a message block using a template
SYNOPSIS
#include <sys/stream.h> mblk_t *allocb_tmpl(size_t size, const mblk_t *tmpl);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
size The number of bytes in the message block. tmpl The template message block.
DESCRIPTION
The allocb_tmpl() function tries to allocate a STREAMS message block using allocb(9F). If the allocation is successful, the db_type field in the the data block structure (dblk_t, see datab(9S)), as well as some implementation-private data, are copied from the dblk_t associated with tmpl. allocb_tmpl() should be used when a new STREAMS message block is allocated. This block is then used to contain data derived from another STREAMS message block. The original message is used as the tmpl argument.
RETURN VALUES
Upon success, allocb_tmpl() returns a pointer to the allocated message block of the same type as tmpl. On failure, allocb_tmpl() returns a NULL pointer.
CONTEXT
allocb_tmpl() can be called from user or interrupt context.
SEE ALSO
allocb(9F), datab(9S), msgb(9S) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 18 Feb 2003 allocb_tmpl(9F)
Related Man Pages
allocb(9f) - sunos
allocb(9f) - linux
allocb(9f) - xfree86
allocb(9f) - hpux
allocb(9f) - posix
Similar Topics in the Unix Linux Community
Block Size
how to retreive a block of data from the file
How to cut data block from .txt file in shell scripting
Reading block by block in XML
Printing a block of lines from a file, if that block does not contain two patterns using sed