sunos man page for samestr

Query: samestr

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

SAMESTR(9F)						   Kernel Functions for Drivers 					       SAMESTR(9F)

NAME
SAMESTR, samestr - test if next queue is in the same stream
SYNOPSIS
#include <sys/stream.h> int SAMESTR(queue_t *q);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Pointer to the queue.
DESCRIPTION
The SAMESTR() function is used to see if the next queue in a stream (if it exists) is the same type as the current queue (that is, both are read queues or both are write queues). This function accounts for the twisted queue connections that occur in a STREAMS pipe and should be used in preference to direct examination of the q_next field of queue(9S) to see if the stream continues beyond q.
RETURN VALUES
SAMESTR() returns 1 if the next queue is the same type as the current queue. It returns 0 if the next queue does not exist or if it is not the same type.
CONTEXT
SAMESTR() can be called from user or interrupt context.
SEE ALSO
OTHERQ(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 SAMESTR(9F)
Related Man Pages
samestr(9f) - opensolaris
canput(9f) - minix
canput(9f) - opendarwin
canput(9f) - xfree86
canput(9f) - hpux
Similar Topics in the Unix Linux Community
Optimizing for loop with awk or anything similar and portable