sunos man page for jaio

Query: jaio

OS: sunos

Section: 7i

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

jaio(7I)							  Ioctl Requests							  jaio(7I)

NAME
jaio - interface to Japanese I/O modules
SYNOPSIS
#include <sys/jaio.h>
DESCRIPTION
This interface is implemented in pushable STREAMS modules that handle Japanese I/O. These are used to query or change the third character of the three character ISO escape sequence for announcing data. These calls take an argument, which is expected to be a pointer to a "kioc" structure, defined in the header file sys/jaio.h, as follows: struct kioc { char ki; char ko; }:
IOCTLS
JA_SKIOC This call changes the 3rd characters of JIS Kanji-In/Out ISO announcement sequences. JA_GKIOC This call returns the 3rd characters of JIS Kanji-In/Out ISO announcement sequences in the "kioc" structure.
EXAMPLES
Example 1: The following is an example of using these ioctls: #include <sys/jaio.h> struct kioc ja_kio; struct strioctl cmd; . . ja_kio.ki = '[input escape char]'; ja_kio.ko = '[output escape char]'; cmd.ic_cmd = JA_SKIOC; cmd.ic_timout = 0; cmd.ic_len = sizeof(kioc_t); cmd.ic_dp = (char *)&ja_kio; ioctl(0, I_STR, &cmd); . .
FILES
/sys/jaio.h
SEE ALSO
jtty(1), jconv7(7M), jconv8(7M) SunOS 5.10 13 Aug 1998 jaio(7I)
Related Man Pages
eucioctl(7) - osf1
euctojis(1) - sunos
sjtojis(1) - sunos
jaio(7i) - sunos
jconv7(7m) - sunos
Similar Topics in the Unix Linux Community
how to change every 3rd character
How to paste Kanji Characters into a Unix File