pprosvc(1M) System Administration Commands pprosvc(1M)
pprosvc - automation service program for Patch Manager
/usr/sbin/pprosvc [-c config-name] [-d [-p patch-id [,patch-id...]]] [-h] [-i [-n] [-p patch-id [,patch-id...]]] [-l]
Note - This command is deprecated. Use the smpatch analyze, smpatch download, and smpatch update commands instead. See the smpatch(1M) man
Use the pprosvc command to analyze a system to determine the list of appropriate patches, download the patches, and apply them. This com-
mand invokes patch operations in response to a user request or at a scheduled time. You must run this command as superuser.
The pprosvc command enables you to do the following:
o Analyze the host system for appropriate patches based on an established configuration
o Generate the list of appropriate patches
o Download the patches to your host system from the Sun patch server
o Apply the patches based on a patch policy
Use the pprosvc -i command to analyze a system, download the appropriate patches, and apply them. If analysis determines that patches are
needed, the pprosvc command downloads them and applies them.
Specify other options to automate a subset of the patch management tasks. If you specify the -d option, your system is analyzed and the
appropriate patches are downloaded to your system. If you specify the -l option, your system is analyzed and the appropriate patches are
The list of patches that is generated by the analysis is based on all of the available patches from the Sun patch server. No explicit
information about your host system or its network configuration is transmitted to Sun. Only a request for the Sun patch set is transmitted.
The patch set is scanned for patches that are appropriate for this host system, the results are displayed, and those patches are optionally
The -d, -i, and -l options are mutually exclusive.
Use the -p option to specify the patches on which to operate. You can use the -p option with the -d and -i options.
The following options are supported:
-c config-name Uses an alternate configuration for the current patch operation. Use the pprosetup command to create new configura-
A configuration named recommended is included. For more information, see ``Specifying Alternate Configurations'' in
the pprosetup(1M) man page.
Note - This feature is not supported by the smpatch command.
-d Downloads the patches that are appropriate for this host system. The patches are downloaded to the designated down-
This option generates a list of appropriate patches, as does the -l option. However, instead of just displaying the
list of patches, the -d option displays and downloads the patches from the Sun patch server. The patches are down-
loaded using a secure connection, and all patches are authenticated using digital signature technology. Only
patches that are signed with a Sun digital signature are stored in your download directory.
Note - Specifying this option is equivalent to running the smpatch download command.
-h Displays information about the command-line options.
-i Applies the patches based on the patch policy. This option analyzes your system to generate a list of appropriate
patches. If analysis determines that patches are needed, the patches are downloaded and applied. If no patches are
permitted to be applied in automatic mode (by running pprosetup -p none), this option is identical to specifying
the -d option.
If only standard patches are permitted to be applied in automatic mode (by running pprosetup -p standard), all
standard patches are applied.
Note - Specifying this option is equivalent to running the smpatch update command.
-l Generates a list of the patches that are appropriate for this host system.
Note - Specifying this option is equivalent to running the smpatch analyze command.
-n Runs pprosvc in automatic mode. The command that the cron job specifies is pprosvc -i -n. To schedule patch opera-
tions to run in automatic mode, see the pprosetup(1M) man page.
In automatic mode, the patch administrator (specified by the -a option) receives email notifications that describe
the patches you downloaded and applied, and any error events that occurred.
Do not use this option on the command line.
Standard patches do not require any special actions on the part of the user. Such patches can be applied by using
the patchadd command (see the patchadd(1M) man page) and do not need the host system to reboot for the patch to
All nonstandard patches are moved to the sequester directory if you use the -n option to run in automatic mode. If
you run in manual mode, however, nonstandard patches that have properties that match the policy specified by ppros-
etup -i are applied. The rest of the nonstandard patches are moved to the sequester directory. You can apply
patches from this directory at a later time. Patches, whether standard or nonstandard, that depend on sequestered
patches are not applied under any circumstances. Such patches are placed in the sequester directory.
For any patch that is placed in the sequester directory, refer to the patch's README file to determine how to apply
it to your system.
Note - This feature is not supported by the smpatch command.
-p [patch-id[,patch-id,.Designates the specific patches on which to operate. Use this option with the -d option or the -i option. The list
of patch IDs must be separated by commas.
The specified patches are adjusted to use the current versions based on the patch baseline. Patches that are
required by the specified patches are added to the complete list of patches to be applied.
Note - Specifying this option is equivalent to specifying the -i option to the smpatch analyze, smpatch download,
and smpatch update commands.
Example 1: Applying Specific Patches in Manual Mode
# pprosvc -i -p 102893-01,106895-09,106527-05
Applies patches 102893-01, 106895-09, and 106527-05 to the local system in manual mode.
Example 2: Analyzing a System and Downloading Appropriate Patches
# pprosvc -i
Performs an analysis of the current system and downloads the appropriate patches based on all the patches from the Sun patch server. The
resulting list of patches can be very long.
Example 3: Applying Patches From the Recommended Configuration
# pprosvc -c recommended -i
Uses the recommended configuration to perform an analysis of the current system and downloads the appropriate patches. Standard patches and
those needed from the recommended configuration are applied to the system based on the established patch policy. For information about set-
ting the patch policy for manual mode, see the description of the -i option on the pprosetup(1M) man page.
See the attributes(5) man page for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Availability |SUNWpprou |
|Interface Stability |Obsolete |
patchadd(1M), patchrm(1M), pprosetup(1M), smc(1M), smpatch(1M), attributes(5)
SunOS 5.10 7 May 2004 pprosvc(1M)