VOP_REMOVE(9) BSD Kernel Developer's Manual VOP_REMOVE(9)NAME
VOP_REMOVE, VOP_RMDIR -- remove a file or directory
SYNOPSIS
#include <sys/param.h>
#include <sys/vnode.h>
int
VOP_REMOVE(struct vnode *dvp, struct vnode *vp, struct componentname *cnp);
int
VOP_RMDIR(struct vnode *dvp, struct vnode *vp, struct componentname *cnp);
DESCRIPTION
These entry points remove files and directories respectively.
The arguments are:
dvp The vnode of the directory.
vp The vnode of the file to be removed.
cnp Pathname information about the file.
LOCKS
Both dvp and vp should be locked on entry and remain locked on return.
RETURN VALUES
Zero is returned on success, otherwise an error code is returned.
ERRORS
[EPERM] The file is immutable.
[ENOTEMPTY] An attempt was made to remove a directory which is not empty.
SEE ALSO vnode(9), VOP_LOOKUP(9)AUTHORS
This manual page was written by Doug Rabson.
BSD July 24, 1996 BSD
Check Out this Related Man Page
VOP_CREATE(9) BSD Kernel Developer's Manual VOP_CREATE(9)NAME
VOP_CREATE, VOP_MKNOD, VOP_MKDIR, VOP_SYMLINK -- create a file, socket, fifo, device, directory or symlink
SYNOPSIS
#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/namei.h>
int
VOP_CREATE(struct vnode *dvp, struct vnode **vpp, struct componentname *cnp, struct vattr *vap);
int
VOP_MKNOD(struct vnode *dvp, struct vnode **vpp, struct componentname *cnp, struct vattr *vap);
int
VOP_MKDIR(struct vnode *dvp, struct vnode **vpp, struct componentname *cnp, struct vattr *vap);
int
VOP_SYMLINK(struct vnode *dvp, struct vnode **vpp, struct componentname *cnp, struct vattr *vap, char *target);
DESCRIPTION
These entry points create a new file, socket, fifo, device, directory or symlink in a given directory.
The arguments are:
dvp The locked vnode of the directory.
vpp The address of a variable where the resulting locked vnode should be stored.
cnp The pathname component created.
vap The attributes that the new object should be created with.
target The pathname of the target of the symlink.
These entry points are called after VOP_LOOKUP(9) when an object is being created.
LOCKS
The directory, dvp will be locked on entry and must remain locked on return. If the call is successful, the new object will be returned
locked.
RETURN VALUES
If successful, the vnode for the new object is placed in *vpp and zero is returned. Otherwise, an appropriate error is returned.
ERRORS
[ENOSPC] The file system is full.
[EDQUOT] The user's file system space or inode quota would be exceeded.
SEE ALSO vnode(9), VOP_LOOKUP(9)HISTORY
The function VOP_CREATE appeared in 4.3BSD.
AUTHORS
This manual page was written by Doug Rabson.
BSD July 24, 1996 BSD
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)