VOP_PATHCONF(9) BSD Kernel Developer's Manual VOP_PATHCONF(9)NAME
VOP_PATHCONF -- return POSIX pathconf information
SYNOPSIS
#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/unistd.h>
int
VOP_PATHCONF(struct vnode *vp, int name, int *retval);
DESCRIPTION
The arguments are:
vp The vnode to get information about.
name The type of information to return.
retval The place to return the information.
The value of name specifies what should be returned:
_PC_LINK_MAX The maximum number of links to a file.
_PC_NAME_MAX The maximum number of bytes in a file name.
_PC_PATH_MAX The maximum number of bytes in a pathname.
_PC_PIPE_BUF The maximum number of bytes which will be written atomically to a pipe.
_PC_CHOWN_RESTRICTED Return 1 if appropriate privileges are required for the chown(2) system call, otherwise 0.
_PC_NO_TRUNC Return 1 if file names longer than KERN_NAME_MAX are truncated.
RETURN VALUES
If name is recognized, *retval is set to the specified value and zero is returned, otherwise EINVAL is returned.
SEE ALSO pathconf(2), vnode(9)AUTHORS
This manual page was written by Doug Rabson.
BSD July 24, 1996 BSD
Check Out this Related Man Page
VOP_PATHCONF(9) BSD Kernel Developer's Manual VOP_PATHCONF(9)NAME
VOP_PATHCONF -- return POSIX pathconf information
SYNOPSIS
#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/unistd.h>
int
VOP_PATHCONF(struct vnode *vp, int name, int *retval);
DESCRIPTION
The arguments are:
vp The vnode to get information about.
name The type of information to return.
retval The place to return the information.
The value of name specifies what should be returned:
_PC_LINK_MAX The maximum number of links to a file.
_PC_NAME_MAX The maximum number of bytes in a file name.
_PC_PATH_MAX The maximum number of bytes in a pathname.
_PC_PIPE_BUF The maximum number of bytes which will be written atomically to a pipe.
_PC_CHOWN_RESTRICTED Return 1 if appropriate privileges are required for the chown(2) system call, otherwise 0.
_PC_NO_TRUNC Return 1 if file names longer than KERN_NAME_MAX are truncated.
RETURN VALUES
If name is recognized, *retval is set to the specified value and zero is returned, otherwise EINVAL is returned.
SEE ALSO pathconf(2), vnode(9)AUTHORS
This manual page was written by Doug Rabson.
BSD July 24, 1996 BSD
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)