VGONE(9) BSD Kernel Developer's Manual VGONE(9)NAME
vgone -- prepare a vnode for reuse
SYNOPSIS
#include <sys/param.h>
#include <sys/vnode.h>
void
vgone(struct vnode *vp);
DESCRIPTION
The vgone() function prepares the vnode to be destroyed. The preparation includes the cleaning of all file system specific data and the
removal from its mount point vnode list.
If the vnode has a v_usecount of zero, and its VI_DOOMED flag is not set, it is moved to the head of the free list as in most cases the vnode
is about to be reused, or its file system is being unmounted.
The vgone() function takes an exclusively locked vnode, and returns with the vnode exclusively locked.
SEE ALSO vnode(9)AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD November 12, 2010 BSD
Check Out this Related Man Page
INSMNTQUE(9) BSD Kernel Developer's Manual INSMNTQUE(9)NAME
insmntque, insmntque1 -- associate a vnode with a mount
SYNOPSIS
#include <sys/param.h>
#include <sys/vnode.h>
int
insmntque(struct vnode *vp, struct mount *mp);
int
insmntque1(struct vnode *vp, struct mount *mp, void (*dtr)(struct vnode *, void *), void *dtr_arg);
DESCRIPTION
The insmntque() function associates a vnode with a mount. This includes updating v_mount for the vnode, and inserting the vnode into the
mount's vnode list.
The mount reference count is incremented for each vnode added to the mount, and that reference is decremented by vgone(9).
The mount's interlock is held while the vnode is inserted. For MP-safe file systems, the vnode must be exclusively locked.
On failure, insmntque() calls vgone(9) on the supplied vnode, and then drops the vnode lock and reference. If more elaborated cleanup after
insmntque() failure is needed, the insmntque1() function may be used instead. The dtr argument is a pointer to a function that is called on
failure. This function may perform any custom cleanup. The vnode pointer is supplied as the first argument to dtr. The dtr_arg argument is
the second, supplying any additional context needed.
RETURN VALUES
The insmntque() function will always return 0, unless the file system is currently being unmounted in which case it may return EBUSY. Also,
insmntque() may be forced to insert the vnode into the mount's vnode list by setting the VV_FORCEINSMQ flag in the vnode v_flag, even if the
file system is being unmounted.
SEE ALSO vgone(9)AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD September 8, 2008 BSD
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)