DEVICE_GET_IVARS(9) BSD Kernel Developer's Manual DEVICE_GET_IVARS(9)NAME
device_get_ivars, device_set_ivars -- access bus private variables
SYNOPSIS
#include <sys/param.h>
#include <sys/bus.h>
void *
device_get_ivars(device_t dev);
void
device_set_ivars(device_t dev, void *ivar);
DESCRIPTION
The device_get_ivars() function returns the bus-specific instance variables of a device.
The device_set_ivars() function sets the bus-specific instance variables of a device.
Typically, only bus drivers will use these functions. The kernel assumes that the bus driver will manage this memory, and no automatic mem-
ory allocation or deallocation happens. Client drivers should access ivars through the BUS_READ_IVAR(9) interface instead.
SEE ALSO device(9)AUTHORS
This manual page was written by Doug Rabson.
BSD June 16, 1998 BSD
Check Out this Related Man Page
DEVICE_GET_SOFTC(9) BSD Kernel Developer's Manual DEVICE_GET_SOFTC(9)NAME
device_get_softc -- access driver private instance variables
SYNOPSIS
#include <sys/param.h>
#include <sys/bus.h>
void *
device_get_softc(device_t dev);
DESCRIPTION
Return the driver-specific state of dev. The softc is automatically allocated and zeroed when the device is attached. The softc is also
initialized and present when a device is probed, but is subject to caveats as described in DEVICE_PROBE(9). The size of the allocation is
determined by the device's driver_t information used to define the driver. The softc typically encapsulates the state of this instance of
the device.
Driver writers are discouraged from using their own softc management mechanisms. Driver writers should not copy such mechanisms found in
drivers in the tree that predate this function.
RETURN VALUES
The pointer to the driver-specific instance variable is returned.
SEE ALSO device(9), DEVICE_PROBE(9), device_set_softc(9), driver(9)AUTHORS
This manual page was written by Doug Rabson.
BSD August 2, 2005 BSD
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)