osx man page for vop_inactive

Query: vop_inactive

OS: osx

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VOP_INACTIVE(9) 					   BSD Kernel Developer's Manual					   VOP_INACTIVE(9)

NAME
VOP_INACTIVE, VOP_RECLAIM -- reclaim file system resources for a vnode SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_INACTIVE(struct vnode *vp, struct thread *td); int VOP_RECLAIM(struct vnode *vp, struct thread *td); DESCRIPTION
The arguments are: vp The vnode being reclaimed. VOP_INACTIVE() is called when the kernel is no longer using the vnode. This may be because the reference count reaches zero or it may be that the file system is being forcibly unmounted while there are open files. It can be used to reclaim space for 'open but deleted' files. VOP_RECLAIM() is called when a vnode is being reused for a different file system. Any file system specific resources associated with the vnode should be freed. LOCKS
For VOP_INACTIVE, the vp will be locked on entry. Your VOP_INACTIVE code must unlock the vp prior to returning. For VOP_RECLAIM, the vp will not be locked on entry and should be left unlocked on return. SEE ALSO
vnode(9) AUTHORS
This manual page was written by Doug Rabson. BSD
July 24, 1996 BSD
Related Man Pages
vrele(9) - debian
vunref(9) - debian
vrele(9) - freebsd
vput(9) - linux
vrele(9) - centos
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
When is a _function_ not a _function_?
My first PERL incarnation... Audio Oscillograph
Syntax error in subtraction in Bash
Python: Refer a properties file from different location