osx man page for vop_getacl

Query: vop_getacl

OS: osx

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VOP_GETACL(9)						   BSD Kernel Developer's Manual					     VOP_GETACL(9)

NAME
VOP_GETACL -- retrieve access control list for a vnode SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> #include <sys/acl.h> int VOP_GETACL(struct vnode *vp, acl_type_t type, struct acl *aclp, struct ucred *cred, struct thread *td); DESCRIPTION
This vnode call may be used to retrieve the access control list (ACL) from a file or directory. Its arguments are: vp The vnode of the file or directory. type The type of ACL to retrieve. aclp A pointer to an ACL structure to receive the ACL data. cred The user credentials to use in authorizing the request. td The thread requesting the ACL. The cred pointer may be NULL to indicate that access control checks are not to be performed, if possible. This cred setting might be used to allow the kernel to authorize ACL retrieval that the active process might not be permitted to do. The vnode ACL interface defines the syntax, and not semantics, of file and directory ACL interfaces. More information about ACL management in kernel may be found in acl(9). LOCKS
The vnode will be locked on entry and should remain locked on return. RETURN VALUES
If the aclp pointer will point to a valid ACL, then zero is returned. Otherwise, an appropriate error code is returned. ERRORS
[EINVAL] The ACL type passed is invalid for this vnode. [EACCES] The the caller does not have the appropriate privilege. [ENOMEM] Sufficient memory is not available to fulfill the request. [EOPNOTSUPP] The file system does not support VOP_GETACL(). SEE ALSO
acl(9), vnode(9), VOP_ACLCHECK(9), VOP_SETACL(9) AUTHORS
This manual page was written by Robert Watson. BSD
December 23, 1999 BSD
Related Man Pages
vop_getacl(9) - freebsd
vop_getacl(9) - opensolaris
vop_setacl(9) - centos
vop_getacl(9) - suse
vop_getacl(9) - hpux
Similar Topics in the Unix Linux Community
Shopt -s histappend
To print diamond asterisk pattern based on inputs
My first PERL incarnation... Audio Oscillograph
A dash to GOTO or a dash from GOTO, that is the question...
Python: Refer a properties file from different location